Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a directory tree with the permission for others as none. I need to change it to read.

I execute this command:

chmod -R o+r My\ Dir

However, it doesn't seem to work for directories, as apache cannot access the files within them. When I open the permissions tab for the directory in Thunar, it says:

Folder permissions are inconsistant and you may not be able to work with files in this folder.

It also has a button to fix it, but I can't do this for all the directories (as there are too many)

What am I doing wrong?

share|improve this question
up vote 8 down vote accepted

You need to set the directories o+x. EDIT: To do this recursively, type

find . -type d -exec chmod o+x {} \;
share|improve this answer

opening folders is not reading them but rather executing them (in terms of priviliges) so Kims anwser consering setting execute flag is correct (+x)

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .