Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a report from someone asking a programming question on StackOverflow that when they pasted valid code

[(1, "google"), (2, "facebook"), (3, "apple")]

from Notepad++ into StackOverflow, it appeared as

[(1; "google"); (2; "facebook"); (3; "apple")]

(and they did not notice until after they submitted their question).

How should Notepad++ users configure Notepad++ to not mangle text like this?

share|improve this question
    
Works fine for me. I just typed out what you posted here and the copied it from Notepad++ to the answer box and it worked fine. –  ChrisF May 4 '12 at 12:21
2  
Did you set Notepad++ to CSV mode or something like that? ; is the CSV field separator in some locales. What are the Notepad++ and Windows locale settings? –  Daniel Beck May 4 '12 at 12:24
1  
Any add-ons installed to Notepad++? Some code helpers may be able to automatically "correct" the commas to semicolons. –  techturtle May 4 '12 at 15:19

1 Answer 1

Make sure you have the latest version of Notepad++. With the default settings, there should be no issues copy-pasting code onto StackOverflow. I do it almost everyday and the snippet you posted works just fine.

If you're worried about porting all your preferences/styles/shortcuts and all other customization to the new version, just follow the steps shown here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.