Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I set up my default shell on ubuntu to be sudosh2 instead of the default /bin/bash.

Now when I ssh into the account, I get some presumably bare-bones shell behavior (only $ prompt, arrow keys result in ^[[D, etc.)

What does that mean, and how do I get a normal bash shell to load, without having to manually start /bin/bash every time I ssh in?

share|improve this question
up vote 1 down vote accepted

What you're seeing is the /bin/sh shell, which never supported arrow keys or other such features in the first place. Its default prompt is $.

Edit the "default shell" parameter in /etc/sudosh2.conf to launch bash instead.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .