Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I upgraded my Xubuntu from 11.10 to 12.04 LTS. After this, I noted that ssh is no more installed. I tried install it and got this error:

we@nemesis:~$ sudo apt-get install openssh-client
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 openssh-client : Depends: libgssapi-krb5-2 (>= 1.10+dfsg~) but 1.9.1+dfsg-1ubuntu2.2 is to be installed
E: Unable to correct problems, you have held broken packages.

I tried to do apt-get clean apt-get autoremove apt-get update apt-get upgrade apt-get install -f. Nothing of this is not helped.

apt-get install dist-upgrade wants me to uninstall my X11:

we@nemesis:~$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  xorg xserver-xorg xserver-xorg-input-evdev xserver-xorg-video-all xserver-xorg-video-ati xserver-xorg-video-cirrus
  xserver-xorg-video-fbdev xserver-xorg-video-geode xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga
  xserver-xorg-video-neomagic xserver-xorg-video-nouveau xserver-xorg-video-openchrome xserver-xorg-video-qxl xserver-xorg-video-r128
  xserver-xorg-video-radeon xserver-xorg-video-s3 xserver-xorg-video-savage xserver-xorg-video-siliconmotion xserver-xorg-video-sis
  xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident xserver-xorg-video-vesa xserver-xorg-video-vmware
  xubuntu-desktop
The following packages have been kept back:
  chromium-browser chromium-browser-l10n firefox firefox-globalmenu glib-networking libnm-glib4 libnm-util2 liborbit2 libsmbclient
  libutouch-geis1 network-manager openjdk-6-jre samba-common-bin simple-scan software-center zeitgeist-core
The following packages will be upgraded:
  xserver-xorg-core xserver-xorg-input-synaptics
2 upgraded, 0 newly installed, 27 to remove and 16 not upgraded.
Need to get 1.747 kB of archives.
After this operation, 8.098 kB disk space will be freed.
Do you want to continue [Y/n]? n

I am afraid to do this, because not I am not sure, that after that I'll have ability to reinstall X11.

How to fix this broken packages?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Ok, it was really stupid thing: couple weeks ago I tried to install some packages from next release and edited /etc/apt/preferences to pin new release precise with lowest priority.

This pinning prevented apt-get to normally install any new packages from new release.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.