Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have encoded some videos using mencoder, with AAC and h.264. Sony vegas cannot open the files, without any explanation. Here is what Gspot tells me about the videos :

enter image description here

To encode the videos I have used :

-oac faac -faacopts br=160:mpeg=4:object=2 -srate 48000 -channels 2
-ovc x264 -x264encopts pass=1:preset=slow:keyint=200:crf=19:level_idc=31:colormatrix=bt709
sourceVideo.avi -o destinationVideo.mp4

previous edits :

The obvious problem seems to be the AAC codec, but I cannot find it. I've included it as a dll in mencoder, but I can't seem to find it for windows.

EDIT: I've read that AAC encoder need a licence, but here I'm only trying to read it in Vegas...

EDIT2 : I have tried installing the K-Lite codec pack, no change. Sony Vegas cannot open a file encoded with h264, neither can it read audio encoded in AAC. Is this normal ?

share|improve this question
    
I have re-encoded the audio as mp3, but Vegas still refuses to open it :( –  Manu May 10 '12 at 14:43
    
I cannot open either xvid/aac or 264/mp3 –  Manu May 10 '12 at 14:59
    
Try to install a serious codec pack such as K-Lite. –  harrymc May 10 '12 at 16:47
    
No, it didn't help :( –  Manu May 10 '12 at 17:59
add comment

3 Answers

up vote 1 down vote accepted
+50

It seems that the 64 bits version of Vegas Pro can't use 32 bits codecs so maybe this is your problem.

Some people recommand to install both versions of Sony Vegas (32 bits and 64 bits).
Also, it seems that there are several codec packs depending on the version you use :

Win7codecs works for 32bit vegas and x64codecs works for 64bit vegas

share|improve this answer
1  
Moreover, someone has a similar issue here. "Ah, I fixed it! What I did was uninstall all codecs, went into CCleaner64 and fixed registry files and uninstalled the codecs from there. Then I went and re-downloaded Win7Codec Pack v279, along with x64Components_v283. Installed these and my files can be seen again in Vegas!" –  Julien N May 12 '12 at 12:27
add comment

I see that the audio codec is FAAD AAC. K-Lite has AAC, but I'm not sure about the FAAD variant.

The only codec I was able to find for you to try is CoreAAC Directshow filter (dating from 2006 but worth trying). Reboot before trying, just in case.

VLC has its own codecs, so this is why it works.

share|improve this answer
    
I installed the K-lite codec pack, now g-spot confirms that both a 264 and a aac decoder are present. Yet Vegas refuses to open them. –  Manu May 11 '12 at 10:52
    
Try to install in addition the CoreAAC Directshow filter. –  harrymc May 11 '12 at 12:08
    
Didn't help either. –  Manu May 11 '12 at 17:01
    
You could try to install in addition K-Lite Codec Pack 64-bit. If this doesn't help, could you post one small problematic file ? –  harrymc May 11 '12 at 19:01
    
dl.free.fr/rH5ltl9RO –  Manu May 11 '12 at 19:28
show 3 more comments

Try installing this AAC ACM codec:

http://fcchandler.home.comcast.net/~fcchandler/index.html

I have re-encoded the audio as mp3, but Vegas still refuses to open it

Encoder and Decoder are 2 different, often separate things. Just because you can encode it in mp3, doesn't mean you can decode it.

For mp3 there's an encoder AND decoder.

share|improve this answer
    
I have created 4 video files, combinations of AAC-mp3 and h264-xvid. Vegas can only open the xvid/mp3 –  Manu May 11 '12 at 10:31
    
If you can't open the h264, something is wrong with your h264 codec. I always use this x264 build: komisar.gin.by –  Don Salva May 12 '12 at 7:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.