Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This is a case of not reading before doing.

I wanted to start clean with Lion Server, so I did what I normally do, drag the app to the trashcan and re-install it. (not realizing that server was a bit more involved than most other applications) I'm now unable to connect to the server via Server.app.

After I select the server and enter my username and password the connecting spinner spins forever. dtruss on both Server.app and servermgrd really didn't tell me much. I can connect to :311 with a web browser, so it appears that servermgrd is working to some extent.

Things I've noticed: /etc/apache2.before-restore.... directories /etc/certificates.before-restore... directories

/var/servermgrd/*.lock (with old dates)

Anyone have a clue on how to:

  1. get connected to Lion Server again
  2. failing that, a way to completely remove lion server so I can re-install
  3. Another place to look/check etc. so I can continue debugging, I'm a bit stuck at the moment.

Clarification: I've installed the Lion-Server package on my desktop. This isn't headless server hardware.

share|improve this question
    
Have you tried SSH? – Kyle May 4 '12 at 19:04
    
ssh works fine. Server.app is the lion-server management interface. Totally unrelated to remote login etc. – skarface May 4 '12 at 19:33

If you do have remote login you should be able to force a reinstall of server.app from the app store. Give something like this a try:

http://apple.stackexchange.com/questions/7075/how-can-i-reinstall-an-application-that-the-mac-app-store-thinks-is-installed-al

Then reinstall it.

share|improve this answer
    
Thanks for the link. I'll give this a shot when I get some time this weekend. Will update on result. – skarface May 4 '12 at 21:25
    
Ran through that, no difference. (tried turning on some services by hand, starting opendirectory via launchctl forced a restore from time machine) I think I'm going to need a full re-install – skarface May 5 '12 at 12:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .