Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've recently downloaded Android x86 (Android 4.0) and installed it in VirtualBox using using android-x86-4.0-RC1-eeepc.iso. Everything is working fine except the Internet connection. I've tried searching for a solution but none of them works for me.

I'm using a Samsung notebook with a wireless connection on Ubuntu 11.10.

Here's a screenshot of the network settings of the VirtualBox:

enter image description here

I've even tried with NAT, but it still dosen't work.

share|improve this question
    
Don't know much about android but your wifi connection will only work from VB if it is connected via USB –  BJ292 May 4 '12 at 19:27
    
@BJ292 I've used similar settings for windows 7 in virtualbox and it works, not sure whats wrong with android settings. –  Searock May 5 '12 at 6:14
    
There is a made for VBox version here that seems to work: addictivetips.com/windows-tips/… - I notice in VBox that networking is configured for port forwarding and in Android it shows Internet Not Connected but works anyway. –  BJ292 May 5 '12 at 10:01
add comment

1 Answer 1

up vote 1 down vote accepted

There is one made for VirtualBox that seems to work, see How To Run Android 4.0 ICS On Windows, Mac & Linux Using VirtualBox. I notice in VirtualBox that networking is configured for port forwarding and in Android it shows

Internet Not Connected

but it works anyway.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.