Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Running Windows 7 (64 and 32-bit), experiencing an issue with mapped drives. Even though I can access the mapped drives contents fine, they show with a red X (see image). Does anyone know the solution for this issue?

enter image description here

share|improve this question
    
It seems it is a problem with Vista, allegedly fixed on a SP (support.microsoft.com/kb/938062 -- although friends corroborate still exists after SP), but present on Windows 7. –  user4553 Sep 16 '09 at 14:01
add comment

2 Answers

This old Microsoft support article says:

On a computer that runs one of the versions of Windows that is listed at the beginning of this article, if you map a drive to a network share, the mapped drive may be disconnected after a regular interval of inactivity, and Windows Explorer may display a red "X" on the icon of the mapped drive. However, if you try to access or browse the mapped drive, it reconnects quickly.

This behavior occurs because Windows NT Server 4.0, Windows 2000 Server, and Windows Server 2003 can drop idle connections after a specified time-out period (by default, 15 minutes) to prevent wasting server resources on unused sessions.

To resolve this behavior, change the default time-out period on the shared network computer. To do this, use one of the following methods.

It then describes a regedit operation that seems still valid on my Vista machine, but which I can't actually test.

share|improve this answer
    
No, this occurs on a newly mapped resource. And it does not goes away. –  user4553 Sep 16 '09 at 14:03
    
Question: is the newly mapped resource marked as persistent? –  harrymc Sep 16 '09 at 14:35
    
Yes, mapped as persistent. –  user4553 Sep 16 '09 at 15:29
    
I believe that the above article is probably just as true for new and old mapped drives. Why would the fact that the mapping is new on the client side, change the way that the server works with network connections? –  harrymc Sep 16 '09 at 16:02
    
I can't answer your question. What I tried to say is, the behavior is observed on newly mapped resources, as well as on resources that were mapped for a while. I know it is an issue on Windows Vista/7, since I have research it. I am just looking for a "home medicine" for an issue, for which Microsoft provides little to no help. –  user4553 Sep 16 '09 at 16:58
show 1 more comment

After you access the drive, have you tried hitting F5 to refresh the My Computer page? I think I've seen this in the past and Windows just needed to redraw the page.

share|improve this answer
    
Yes, tried, no change. –  user4553 Sep 16 '09 at 13:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.