Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using dyndns, a lynksis wt54g router, and tomcat 7 with spring to set up a web server. This is my first time to attempt this. I'm sure this is a very common question, but I don't know enough to find the answer after quite a bit searching. Dyndns is successfully forwarding to my ip. The main problem is, the router admin login is coming up when my url is used. I'm hosting my site on port 8080. I have port forwarding set up for port 8080 but my request times out when I attempt to use my url like this www.myurl1234.com:8080. I don't want users to have to type the port anyway. I also tried changing the management port to 82 and hosting on port 80, but I still get the router admin login when I use my url. Where am I going wrong? Can I set it up so that www.myurl1234.com goes straight to port 8080?

share|improve this question

migrated from serverfault.com May 5 '12 at 3:42

This question came from our site for system and network administrators.

    
You can set up a web server on port 80 and from there use HTTP or JavaScript to forward the browser to port 8080 on the same host, but you can't make example.com route to example.com:8080. Port 80 is the default port for HTTP, so unless you tell the browser to connect to the host at a different port, that's the port it will use. –  Lèse majesté May 5 '12 at 4:48
    
You say that you have port 8080 forwarded by your Router... Is your web server on your machine configured to Listen on the 8080 port? Are you running these URL queries on a machine connected to that router? (If so, it will always get the router admin page...) –  mck66productions Sep 21 '12 at 20:05

1 Answer 1

See your router's manual... Sounds like you have it badly misconfigured if the management page is publicly available.

share|improve this answer
    
Second this, move the routers page from port 80, set a good password on it, and forward port 80 to your internal server. –  fstx May 5 '12 at 6:31
1  
@fstx: You don't actually need to change port number for the router web admin page. Because if you disable remote administration, then the router's embedded web server won't bind to the public IP, and you can just forward outside connections to port 80 directly to your server. And other hosts on your LAN would be connecting to your server via its LAN IP. –  Lèse majesté May 5 '12 at 13:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.