Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I experience intermittent problems where my mouse won't click and hold, so I cannot select text or draw a box or anything in Photoshop. I have encountered this issue with Adobe Photoshop CS4 and lately Outlook 2010 and Word 2010, which indicates it's not software related.

I have also tried a different mouse and a different USB port, with the same result.

My keyboard malfunctions as well, almost as if I am holding in the function button or something: I press A but in return it types a 1, or a CTRL or something. I have similarly tried a different keyboard with no success.

I have a Logitech k800 keyboard with a MX revolution mouse.

As mentioned above there isn't something which I could say "triggers" it, but it happens daily, and I am forced to restart when it happens. They also don't both malfunction at the exact same time. For example, sometimes the mouse would start to weird out but would start working again after a while (such as if I open another program or website), but when the keyboard scrambles I need to restart to fix it.

I am running Windows 7 64bit ultimate, any suggestions?

EDIT:

For what it's worth, it appears to happen when I select a string of text, and then delete it with the delete button. Straight after that my mouse will not drag anymore, and I have to go into Firefox, and on return I can drag again.

share|improve this question
    
Did you try connecting your KB & mouse to the front panel USB port? Taking a shot in the dark here but it sounds like something is going on with the onboard USB controller. Did you try doing this while keeping all other USB devices disconnecting? Reason why I'm suggesting to use the front panel is that it may be on a different controller from the back panel. IF you have USB 3.0 ports vs. 2.0 ports, definitely connect your KB & mouse to the other set, since I believe the 3.0 ports run on a different controller from the 2.0 ports. –  White Phoenix May 5 '12 at 10:55
    
found the issue, it was synergy which remaps like crap :/ –  Mauritz Swanepoel May 6 '12 at 18:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.