Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On my MacBook, the default SVN client was the version 1.4, and I installed subversion (ver. 1.7) from MacPorts. But when I run svn from terminal, it still launches the old SVN 1.4.

echo $PATH gives /opt/local/bin:/opt/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/texbin:/usr/X11/bin

which svn gives /usr/bin/svn.

I just noticed that MacPorts failed to install some dependencies, so SVN was not installed properly.

share|improve this question
    
What's the output of echo $PATH, what's the output of which svn? What's the output of find /opt/local -name svn? –  Daniel Beck May 5 '12 at 10:04
    
@DanielBeck: I edited the question –  Jakub M. May 5 '12 at 10:15
    
Errrr just noticed that macports failed to install some dependencies, so svn was not installed properly (apr) –  Jakub M. May 5 '12 at 10:21
    
port installed would have been my next suggestion :-) You could probably profit from a shell that displays the last command's exit code like I present here: blog.superuser.com/2011/09/21/… –  Daniel Beck May 5 '12 at 10:23
1  
Jakub, is your problem solved now? Or are you still stuck at installing the dependencies? –  slhck May 5 '12 at 22:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.