Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

If I type in terminal

sudo ./lampp startmysql

I get message:

XAMPP: Couldn't start MySQL!

I also tried wtih panel

sudo ./lampp panel

There it says that Apache and PROFTPD are both running but MySQL is stopped. If I try to run it in XAMPP Control Panel I get the following error in console:

/opt/lampp/lampp: line 252: echo: write error: Broken pipe
/opt/lampp/lampp: line 257: echo: write error: Broken pipe

What is the problem and how could I run MySQL? Restarting XAMPP doesn't work. Please help

share|improve this question
    
Have you set the permissions on the /opt/lampp directory correctly? It appears like something is trying to write to a log file, but doesn't have the permission to do so. – Breakthrough May 6 '12 at 14:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.