Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to move a file from a usb stick to a folder on my desktop.

I have changed the various properties on it and its subfolder items and taken ownership of it. I have added full permissions to do everything on it and its subfolders and items.

When I try to move the folder, windows 7 gives me the error message:

You need permission to perform this action You require permission from XXX\YYY to make changes to this file

(Try again / Skip / Cancel) Do this for all current items (x amount found)

The thing is, I am actually logged in as user XXX\YYY, and so getting this message does not make sense. Even when I hit try again, it doesnt work.

What is going on here and how can I first of all change the permissions so I can move the stuff.

Second, I am the only person using this computer (its my laptop and I live alone (poor me)). These permissions are really annoying. Is there any way I can disable this level of security on my system for good so I can just take ownership of the files once they get on to my system and then do what I want with them. Where are the days of good old dos.

Thanks in advance for any help you can provide.

share|improve this question

migrated from stackoverflow.com May 6 '12 at 22:25

This question came from our site for professional and enthusiast programmers.

you should be able to move a file from usb to disk withouth messing up with any permissions and taking ownership is absolutely unessessery in that case. I don't know why you have changed the properties of the usb but try giving full control on the usb to the Everyone group. Also try starting Windows Explorer as administrator - (right click .> Run as administrator).

You can't avoid file permissions, but you can reduce or turn off User account control (UAC). Control Panel (view by small/big icons) -> Change User account Control settings

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .