Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Bash in my Fedora 16 seems to autocomplete arguments based on the command itself. So if I for example type

cd Tab

… it will only show directories.

There are however far too many commands where it doesn't know the expected input types, so is there any way to disable this feature?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Remove the bash-completion package.

share|improve this answer
    
Works like a dream. Thank you –  MTilsted May 7 '12 at 13:34

Another way to disable it on a per-user basis is by doing complete -r in your .bashrc file. Type help complete for more information.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.