Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been using archlinux for a while but as the only SO in a hard drive. Today I decided to make a dual boot between windows 7 and archlinux, everything works fine but I have the following problem:

I have set the time in arch for example: 20:00, and when I go to Windows it updates to 01:00.

I've found some other posts like this

and a command hwclock --systohc

but is not working, I guess that I've done everything that I had to do in arch and now I have to fix some problems in Windows but I don't know what to fix

I hope somebody can help me with this because its annoying that I have to fix the time every time I start Archlinux/Windows

EDIT

SOLVED

The link on the correct answer works but the way it mentions (creating a file and execute it) didn't work for me so I had to do it myself. In case someone want the path in regedit, read this

http://www.comptalks.com/how-to-fix-incorrect-time-display-in-Windows-when-dual-booting-with-Linux-or-OS-x/

Thanks!!

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

Windows uses local time by default, while Linux uses UTC time. These links may help:

Does Windows 7 support UTC as BIOS time?

https://help.ubuntu.com/community/UbuntuTime#Multiple_Boot_Systems_Time_Conflicts

share|improve this answer
    
Pretty much everyone should do this on every Windows 7 system they own. About the only exception would be if they have to dual-boot with an OS that cannot support having the hardware clock in UTC. –  David Schwartz May 7 '12 at 2:38
    
According to the links I have to set HARDWARECLOCK to "localtime". What I've done was setting the correct time in archlinux, then run the command sudo hwclock --systohc and then rebooting. Then I start windows (with the wrong time) and run that script and restart but nothing happens –  JavierQQ23 May 7 '12 at 2:48
    
@DavidSchwartz so I have to run the script, then update the time and restart? –  JavierQQ23 May 7 '12 at 2:49
    
Run the script and restart. You should only have to set the clock one more time. –  David Schwartz May 7 '12 at 2:59
    
@DavidSchwartz I ran the script and then set the clock to 20:00 but when I restarted arch showed 15:00. I guess there's something I'm missing –  JavierQQ23 May 8 '12 at 2:12
show 1 more comment

You should Change date and time in the following commands.

date --set "2012-05-06 23:54"

Then

hwclock --set --date="2012-05-06 23:54" 

To probe:

hwclock 
lun 07 may 2012 11:34:00 COT  -0.698178 segundos

I have a dual boot computer with Windows XP and Arch Linux.

share|improve this answer
    
I did that, I set it to "2012-05-07 21:00". Then I restarted and nothing happened –  JavierQQ23 May 8 '12 at 2:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.