Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a SanDisk Cruzer Micro 4gb that I use often. Today, after using it to install ubuntu on another pc and plugging it to my main computer, windows 7 refuses to mount it (IE the drive does not appear in "my computer").

The volume DOES appear in the disk manager and device manager ("Disk 4"):

but when I try to assign a drive letter (via right click > change drive letters and path) I get "The system cannot find the file specified"

enter image description here

The really weird thing is that if I disable and re-enable the driver in the device manager, suddenly everything works and the flash drive gets assigned a letter and shows up in "my computer" (The letter J: in this case). I can even change the drive letter now without the error, but this does not remedy the problem.

enter image description here

Even so the next time I unplug and replug the device it reverts to it usual annoying self and does not get mounted (doesn't get a drive letter or appear on "my computer")

Things I've tried to no avail:

  • Rebooting
  • Plugging and unplugging on different USB ports
  • uninstalling and reinstalling the driver (as mentioned has no permanent effect)
  • Changing the drive letter
  • Trying the drive on a different computer (flash drive gets mounted and works perfectly)
  • Re-formatting the drive to FAT32\FAT (look at comment below)
  • Trying in safe mode (still doesn't work)
  • Trying to assign a letter with Diskpart (fails with "the system cannot find the file specified") link:
  • Trying to enable\disable "automount" with diskpart
  • Praying to the flying spaghetti monster (still not go :( )

I'm at a loss... reinstalling windows over this issue seems like overkill. Please advise!

share|improve this question
Do you by chance have network drives? – hydroparadise May 7 '12 at 21:42
@hydroparadise No network drives are mapped this this machine – OpherV May 7 '12 at 21:48
I'm getting this problem at the moment with exactly the same USB drive... Maybe a problem with the drive's driver somewhere – ACarter Nov 25 '12 at 19:50
I have exactly this problem. Found out that this USB drive was formatted by "Disk Ultility" app in Mac OS. Open Mac OS again, plugged this USB drive in and reformat it to FAT32. Now I can see the drive letter when using in Windows OS. – Tuyen Nguyen Jan 24 '14 at 3:46

I ran into the same problem and experienced the same set of symptoms as you.

I eventually resolved this problem by using a third party partition tool to do the following:

  1. Wipe all partitions on the flash drive.
  2. Create a new FAT32 partition encompassing the whole flash drive.
  3. Manually set the drive letter.

In my case, I used the free download MiniTool Partition Wizard Home Edition.

Worked like a charm. No reboot required.

Best of luck!

share|improve this answer

Have you tried reformatting the usb drive. I noticed that in the disk management utility it labeled your drive as a (Logical Drive) as opposed to a active, primary partition. I just tried it with a spare usb drive and after a standard format for me I got:

I also heard somewhere that some logical drives have conflicts when assigning letters. It might have only been with networked drives though.

share|improve this answer
Yes I have. If I try to format it when it's unmounted (by right clicking in disk management and choosing format) I get the same "system cannot find file specified" If I do it after disabling/enabling it formats just fine, but the problem resides. It still shows as "logical" rather than "active, primary" when unplugging, replugging and disabling/enabling – OpherV May 8 '12 at 11:07
That is very strange, you might try formatting the drive on one of the other computers you mentioned it worked on. Then try it with the one you're having issues with. I also had issues once with a flash drive after a linux installation, I think I did a low-level format of the drive to get it working again. Mine usb drive didn't work on other computers though, so it was definitely a drive issue for me. – sm11963 May 9 '12 at 17:45

The Windows disk manager can corrupt the partition table, try using Gparted to create a new partition table and a primary fat32 partition with no flags.

share|improve this answer

I've read out your problem and here is your solution:

  1. Open run dialog box
  2. Now enter diskpart.exe hit enter
  3. Now disk part opens
  4. Enter list disk and hit enter
  5. Remove all your storage flash except your pendrive
  6. Now enter select disk 1 hit enter
  7. Now type clean hit enter
  8. Wait till it completes
  9. Now type create partition primary
  10. Wait till it completes
  11. Now type select partion 1
  12. Now type format fs=fat32
  13. You can use fat and ntfs file system as well
  14. Now type active
  15. Now type assign
  16. You've done
share|improve this answer
Step 6 above is dangerous! You should first run LIST DISK to determine the correct disk number of the drive you wish to clean, otherwise if disk 1 isn't the correct one, you'll irreversibly clean the wrong disk. – Twisty Sep 26 '14 at 14:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .