Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When adding a folder to a Sublime Text 2 project, it doesn't seem to show .git subfolders. It also seems these files cannot be opened by Ctrl-P.

I disabled the Git plugin but that didn't help.

share|improve this question
I can't reproduce. I opened a project directory, then did mkdir .t in the dos-prompt creating a folder, and it showed immediately in the project. In that folder i created t.txt and used Ctrl+P to open it. I'm running build 2181. –  tovare May 7 '12 at 22:45
are you running on windows? I don't know if . make files hidden on windows... –  ufotds May 7 '12 at 22:56

2 Answers 2

up vote 10 down vote accepted

In Sublime Text, go to Preferences -> Settings - Default, scroll down to line 290 and remove .git from 'folder_exclude_patterns' property

share|improve this answer
or better, override it in your user settings! –  Sander Jul 12 '12 at 16:55
The line number will change. Do a search for 'folder_exclude_patterns' instead. –  Snow Crash Oct 29 '14 at 17:14
User settings is probably the right answer but, since you probably want to start with what they have and copy that into your config to be modified rather than making your own list from scratch, I'll mention that as of 2.0.2 folder_exclude_patterns is down to line 327. –  umassthrower Jan 2 at 17:12
Though, now that I look at it, I'm setting mine to [] because it's only scm dirs and I may want to modify items in those dirs for any of them. –  umassthrower Jan 2 at 17:16

Go to Preferences -> Settings-User. Modify the rule folder_exclude_patterns to contain an array of patterns to exclude. I chose to leave it empty:

    "bold_folder_labels": true,
    "caret_style": "phase",
    "color_scheme": "Packages/Color Scheme - Default/Solarized (Dark).tmTheme",
    "font_size": 14,
    "highlight_line": true,
    "line_padding_bottom": 1,
    "line_padding_top": 1,
    "tab_size": 4,
    "translate_tabs_to_spaces": true,
    "folder_exclude_patterns" : [] // the rule in question

share|improve this answer
"Settings - Default" in my case, but good answer, thanks! –  PhysicalEd Jun 17 '14 at 18:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.