Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to fix my Gateway desktop. About 6 months ago it stopped working and since then I started using a laptop. But now I want to fix it since it's much more powerful than my laptop.

The problem is that when I turn it on, the fans start, the hard drive starts spinng but the screen is always blank. Not even a BIOS screen shows up. A clue as to what's wrong may be the fact that when I connect my wireless keyboard the light on it's USB receiver is constantly lit. On a working computer that receiver only lights up when I press a key. But when I connect it to this desktop it's lit non-stop.

Another clue is, when I press and hold the power button it doesn't turn off. But if I unplug the desktop and plug it back in, and it starts again, if I press and hold the power button it shuts off. But it I start it again same problem.

I don't remember what exactly happened the day it stopped working but I don't remember anything crazy happening like a short circuit or anything.

Does anyone have a clue as to what may be wrong?

P.S.

Hard drive isn't corrupt, I was able to open it using a external hard drive connector on my laptop and see it's contents.

share|improve this question
    
Looks like a motherboard failure to me –  Akash May 8 '12 at 6:20
add comment

1 Answer

it looks like normal problem with unused Desktops for long time. So i think Cleanning the dust from RAM slot & Reconnecting the RAM may help you to get bios Screen. if it works let me know.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.