Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Windows XP 32-bit on Windows Vista 64-bit with VirtualBox 3.0.6. Whenever I run the XP VM, Vista (host) reports 100% cpu utilization even though XP (guest) reports between 1-5% cpu utilization.

The host box has 2 GB of physical RAM. The guest/vm is configured with 512 MB. The host box has a 64-bit AMD processor.

No apps (other than VirtualBox) are running on either host, they're just idling.

Any guesses as to why the host processor is spiked?

I've enabled various advanced features for the XP guest in the hopes of having better performance:

  • Settings → System → Motherboard: Enable IO APIC
  • Settings → System → Processor: Enable PAE/NX
  • Settings → System → Acceleration: Enable VT-x/AMD-V and Enable Nesting Paging
share|improve this question
1  
Is it the VM that's hogging the CPU? Can you start Process Monitor and see what are the exact processe(s) using up the CPU cycles and update your answer? –  caliban Sep 16 '09 at 15:54
    
Do you have a VT-x/AMD-V enabled CPU on your host (it might be disabled in your BIOS settings too) –  nos May 31 '10 at 9:29
add comment

10 Answers

Guess I know the answer. Try disabling IO APIC. Whether it be Linux, Windows, I always had a HUGE backfire with this, and a full throtle on my CPU. IO APIC/Multi-core on Virtualbox is for showoff only I guess. If you really want multiple cores, use VMWare Workstation/Player/Parallels desktop. (Player is free.)

share|improve this answer
    
No one checked this? Shame on you guys. :( –  Shiki Aug 19 '10 at 13:35
add comment

In a lot of cases, use of io-acpi with a 32bit guest will do that. You need to have an 64bit guest, or to unactive IO-ACPI and use only one core in your VM.

share|improve this answer
add comment

I experienced this problem running a Windows XP guest on an Ubuntu Intrepid host, and the solution for me was to disable ACPI in Windows XP.

http://forums11.itrc.hp.com/service/forums/bizsupport/questionanswer.do?admit=109447626+1253120112041+28353475&threadId=652377

share|improve this answer
    
To be clear: The link you posted has instructions for disabling ACPI from within the running guest OS, which is different than disabling ACPI on the VirtualBox motherboard. In fact, there is a VirtualBox warning that says APCI should not be disabled on the VirtualBox motherboard after a guest Windows OS is installed. I wonder if disabling the APCI configuration before creating a virtual machine will avoid this issue. –  Greg Mattes Sep 16 '09 at 17:58
    
This suggestion did not help. When I restart my virtual machine guest OS I cannot interact with it at all. A window appears saying that mouse integration is no longer support and that manual capture is required. But capture doesn't seem to work, so I can't access the VM. –  Greg Mattes Sep 16 '09 at 18:13
add comment

I had the same problem with VirtualBox 3.0.6 on a 64-Bit host.

Today, I am using VirtualBox 3.1.8, which works very stable for me and I have no more such problems.

share|improve this answer
add comment

What version of VirtualBox you use? That simptoms was on 3.0.2, and upgrading to 3.0.4 solves this behaviour.

share|improve this answer
    
Thanks for pointing out this omission. I'm running VirtualBox version 3.0.6. I've updated the question to reflect this information. –  Greg Mattes Sep 16 '09 at 17:50
add comment

Is the guest configured with more than one CPU? That seems to still be a bit buggy with some OS combinations, even under 3.0.6.

Did you post up at the VirtualBox forums too, so the developers will see your problem report?

share|improve this answer
    
There is only 1 virtual cpu configured. –  Greg Mattes Sep 16 '09 at 17:47
    
I'll checkout the VirtualBox forums - thanks! –  Greg Mattes Sep 16 '09 at 17:48
add comment

Note that there are much more than just the CPU that is emulated. It could be the IO processor/memory paging etc at work.

That's my blank speculation though.

share|improve this answer
add comment

What process is being shown as taking up the CPU? If it is System you could have something causing the system to cache or PIO mode enabled.

share|improve this answer
add comment

I had this problem on VMWare ESX with a Windows 2000 machine who's machine idle timer (System Idle Process) wasn't properly going to sleep - thus eating all my virtual cycles doing nothing. Perhaps that will lead you to the answer?

share|improve this answer
add comment

ocsid80 is probably right. I am using now 3.0.8 and trying to configure the user setting has little flexibility really. The reasons could be many. These are deep problems rooted in it from what I gather from the virtual box support forums. It could even very well be a result of crazy vista panicing with keeping the demands of virtual box online.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.