Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Have been trying to obtain true color via remote desktop but still get substantial color loss. Below are two pictures showing original image (thanks, Flossmanuals) and its presentation through RDP. Resolution on both ends is set to True Color (of course). Have updated video drivers on both PCs — no luck. Checked with low resolutions, 800x600; enabled HiColor on remote machine's registry — nothing. Have tried from Windows8 to Windows7 and vice versa — color depth lost.

  1. Color Wheel via RDP

  2. Original Color Wheel

Anyone have a clue? Many thank-yous in advance ;)

P.S. Digging some Microsoft manuals found ColorLossLevel (CLL) parameter but could not find if it is set automatically on initialisation or could be set manually.

P.P.S. Still have to try Windows8 <-> Windows8 :)

share|improve this question
    
In windows 7 can I select color to 32bit (Highest Quality). Do you mean that the maximum you have is 24 bit? –  chmod May 8 '12 at 12:06

2 Answers 2

RDP

Here I can choose 32bit

However, I just test your color wheel and even in 32bit, I still get the color loss you're talking about.

share|improve this answer
    
Yes Chmod, thanks for trying and posting. It would be great to find an answer if there is a way around it. –  abrynn May 8 '12 at 13:07

You can get 32bit color, but you will not get the exact same colors/image as the original because the rdp image compression is lossy. You can read about the specs here...

[MS-RDPBCGR]: Remote Desktop Protocol: Basic Connectivity and Graphics Remoting Specification

[MS-RDPNSC]: Remote Desktop Protocol: NSCodec Extension

share|improve this answer
    
Thank you for taking a look, Logman! Looks like I have only RemoteFX left to try, though even there compression should be engaged in the same very way. –  abrynn May 8 '12 at 13:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.