Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am having a issue where i cant get nxhtml working in emacs 24. I have the correct load path

(add-to-list 'load-path "C:/Documents and Settings/stsvyas1/Desktop/emacs/emacs-24.0.94/nxhtml/autostart.el")

I have the files in the correct place and doing C-x-C-e will look like it loads it but i dont get any of the nxhtml commands. Does anyone know how to solve this, or what the issue is? thanks

share|improve this question
    
Is there anything in your Messages buffer to suggest that there was a problem? Does your mode line say you are in nxhtml mode? – Jonathan Arkell May 11 '12 at 15:07
    
When i type nxhtml then press tab to see the completions and it lists none. – Shantanu May 14 '12 at 15:50
up vote 1 down vote accepted

Oh wait.

You don't have the correct load-path at all.

In fact, what you need to do is this:

(load "C:/Documents and Settings/stsvyas1/Desktop/emacs/emacs-24.0.94/nxhtml/autostart.el")
share|improve this answer
    
Hm i really sure research more into elisp. So the issue was that i was not suppose to do add-to-list but just load? thanks again it worked – Shantanu May 16 '12 at 4:26
    
It'll come. load' take the argument passed in, and tries to load it as elisp. When you're doing the (add-to-list 'load-path ...) thing, what that does is just make it so you can (require 'foo-package). – Jonathan Arkell Jun 8 '12 at 2:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .