Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows 7 Ultimate machine where the wireless adapter all of a sudden started having trouble connecting to wireless networks. Whenever I go to a new place and try to connect to a wireless network, it says that the DNS server is not responding, and tells me to go unplug the router and try again. After several locations in a row telling me this, I began to realize something was wrong with my adapter, not the routers.

I am no longer asked to identify the security level for any new networks (Work, Home, or Public) like I used to be (it defaults to Public now - with the park bench icon). Often, resetting the router doesn't even work. Running the Windows 7 troubleshooter doesn't give me anything better than the advice to reset the router. However, the adapter will still connect to the wireless network at my main office without any problems.

Does anyone know why a wireless network adapter can get so finicky so suddenly?

Thanks!

share|improve this question

migrated from serverfault.com May 8 '12 at 20:35

This question came from our site for professional system and network administrators.

    
Disable your modem connection availability. –  user148996 Jul 29 '12 at 16:48
    
Have you checked to make sure you have the latest Wireless Adapter driver from the manufacturer's website? –  Kevin Dodd Jul 29 '12 at 16:58

2 Answers 2

Based on another answer I participated in, you might check your energy management options for the adapter. Windows (in its infinitely helpful wisdom!) might be disabling power to the adapter in some conditions. I remember there being an option worded like "allow windows to disable this device to save power" ... although that's from an XP system, Win7 should have something similar.

Most likely under 'Properties' of the adapter, then 'options' or such.

share|improve this answer
    
Thanks Lomix - I can only find settings similar to that one in the windows 7 power plans (available by clicking on the battery in your system tray, if you're using a laptop). But there doesn't seem to be anything exactly like what you describe, and mine aren't set to allow the adapter to be turned off. –  Andrew B Schultz May 9 '12 at 14:07
    
Yes, there should be advanced energy settings, and a list pops up with various components. There is one for "adapter for wireless network". He says to put it on maximum performance. Example picture (however in dutch) –  Svardskampe Sep 10 '13 at 18:32

Try this:

  • Go to Start → Run, type in cmd and hit Enter

Now enter:

  • ipconfig /release
  • ipconfig /renew

Also try to disable the wireless card and then enable it.

share|improve this answer
    
Hi George, thanks for the tip. I've done that; but the renew always hangs, saying that the operation can't be performed for an adapter that has its media disconnected. It's referring to my wireless network connection 2, which is a microsoft virtual wifi miniport adapter. I don't know what that means or where it's from. But for that reason, or some other, the release/renew doesn't help me get connected to the wireless network. –  Andrew B Schultz May 10 '12 at 3:09
    
Hmm, that should not be there as that is a dev feature. Click on the connection icon and open network center. Select "Change adapter settings" on the right and right mouse button on the virtual wifi miniport adapter and disable. The other adapter, the real one, RMB -> Properties -> Config -> Under Energy, tick off "Computer can disable this to save energy" Now try to do the above commands. –  Svardskampe Sep 10 '13 at 18:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.