Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed Ubuntu under VirtualBox on my Windows 7 machine. All is working okay, except that when I type a hyphen - I get an apostrophe ' instead. This happens on the command line, in the browser, and elsewhere.

Where can I change the keyboard settings to apply the correct character when keys are pressed?

I'm using VirtualBox 4.1.14 and Ubuntu 12.04.

share|improve this question
1  
Could you tell us which type of keyboard do you have and which layout you choose. Note: there are several QWERTY keyboard, try to be more specific if you can. –  Huygens May 8 '12 at 20:50

2 Answers 2

up vote 5 down vote accepted

If you open up the launcher and search for keyboard layout, you get the system dialog which controls what layout you're using. Add your keyboards layout to the list and then set it as the default :)

share|improve this answer
1  
That was it. For some weird reason it was set to "Italian". –  user237815 May 8 '12 at 22:52
  1. Select the large cog in the bottom left hand corner for System Settings.
  2. Select Keyboard layout (not Keyboard).
  3. Use the plus button to add your keyboard.
  4. The minus button to deselect Italian.
share|improve this answer
    
This saved me some tome, as the downloaded vbox image had italian. –  RainDoctor Aug 15 at 23:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.