Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How can you turn off graphics at Ubuntu's GRUB -bootloader such that you can access and see terminal?

I have a 5-year-old Nvidia graphics-card which is not anymore compatible with Linux kernel 2..18 nor 2..14. The problem started after updating the kernel.

I have tried to solve the problem by going to the recovery mode at the GRUB loader.

Everything works except that I can see nothing what is going on. I can login, set my password and then routinely start up Apache server such that I can see my internet site served.

However, I would like to see at least letters. I am not interested in graphics.

share|improve this question

migrated from stackoverflow.com Sep 16 '09 at 17:04

This question came from our site for professional and enthusiast programmers.

up vote 6 down vote accepted

You shouldn't directly delete files from the /etc/rcn.d directories as RageZ has said - you should use the update-rc.d script to manage what starts and what does not.

If you use :

update-rc.d gdm remove

That will stop Ubuntu from attempting to start the Display Manager by default, and should leave you with a nice text prompt.

Using Control+Alt+F1 should work too even if GDM has started already - but sometimes if the drivers are particularly broken, it leaves the graphics card in a state where it can no longer switch modes properly, so removing GDM from the startup is probably a better alternative.

share|improve this answer

I am not sure what window manager you are using but if you are using gnome in console do this

sudo rm /etc/rc2.d/S13gdm

and reboot the machine, this command would prevent X from starting up.

Also you should be able to get a console by pressing Control + Alt + F1.

share|improve this answer

You can force the system to boot in runlevel 1, which will give you a plain text console. At that point you can use the other hints to disable gdm so the next full boot will also result in a text console.

In grub press 'e' and edit the kernel line to add 'single' and hit 'b' to boot.

share|improve this answer

Remove the nvidia xorg driver and drop back to the nv driver.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .