Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Mouse was working fine for more than a year but then suddenly the scroll started to behave weirdly. Like having it's own life it started to move up and down quickly making any computer activity impossible. Things I tried:

  1. Updating drivers
  2. Uninstalling drivers and using none
  3. Plugging it into different USB slots
  4. Cleaning it

None of this helped.

Anyone have a clue how to fix it?

share|improve this question

8 Answers 8

This actually isn't a hardware issue, it's a software issue. I've used this mouse for a long time and it's worked great. I recently bought a second one (so I'd have one to travel with) and installed the latest drivers. Big mistake - ran into the crazy possessed over-sensitive scrolling issues described here. From the Logitech Forums, I found this solution:

  1. Uninstall the SetPoint software (currently at v 6.52)
  2. Donwload and install SetPoint v 6.32 (available here).
  3. In SetPoint, make sure "smooth scrolling" is turned off.

Problem solved.

share|improve this answer
    
I also uninstalled the SetPoint software and this solved the scrolling issue for me. The issue for me seems to be related to running VMs in Virtualbox/VMWare. Perhaps one driver doesn't like the other? –  Nathan Adams Apr 20 '13 at 16:33
1  
It was a hardware issue. Confirmed . –  superego Jun 20 at 9:28

It's most likely a hardware issue.

I mean that or you will need to clean it more intensively, or you will need to get a new one. Because it is most likely due to the mouse wheel sensors being dirty, or simply "tired".

The good point is that Logitech has an excellent support. I recommend you to contact them, to explain the issue. I have a very good experience of their support, they offered in the past to replace my mx1000 which had a malfunction. (They also send you feet for free, you only have to ask the support for this).

The link to the support is here. However, it seems that their mail support is currently being moved, and is unavailable until the 21st of september. You can still call them, though.

Edit: Ok, "tired" was a bit too fast, I couldn't find the word I was looking for. I didn't really mean that sensors are tired, rather that mechanical/physical parts could be, for example in the way the mouse wheel is "held". It could be that the "steps" which are originally on the wheel, are not holding correctly, and any move is turning it, even a bit. It could also be that sensors have a problem, and are simply misplaced or too sensitive.

I suggested more intensive cleaning, but I doubt it will be enough. To me, it's likely that you will have to get a new one (sent by Logitech support or not). But it's not something you can really fix by changing drivers or else.

The only thing which you can do, on software side, is to deactivate actions from the mouse wheel so that it won't bother you anymore (I believe this can be done using AutoHotkey, more details on that if this solution interests you). Though of course you would have to do without a mouse wheel, which is quite disturbing.

share|improve this answer
    
It is a hardware issue. I cleaned it very well. Don't know how sensors get tired but I have let them sleep in my drawer for a year or so already.... Yes - support is not working. –  superego Sep 17 '09 at 10:26
    
Logitech keeps on losing points imho –  Pitto Dec 14 '10 at 16:06

yes, it was I suppose at the optical reader of the wheel. Because I have shake it strongly and made a strong blow into the gap between wheel and mouse cover and suddenly the scrolling wheel works again..

I hope that will last a while otherwise I will be forced to open that which I want to avoid

share|improve this answer
    
This does not make sense as an answer, do you want to change it to a comment to someone's answer? –  Tog Jan 9 '13 at 13:11

I took mine apart and fixed it. The scroll wheel has a light sensor on one side and a lens emitting a ray on the other. the light goes through tiny holes on the wheel from one side to the other and the sensor reads the intervals to make the scroll go.

Anyway, if you are technically savvy - carefully open the three screws on the bottom, then carefully open the mouse. My advise is that you take a few shots with your digital camera to make sure you know how to put it all back together when done. then dismantle the scroll wheel (take more shots if required) - carefully clean all the dust and grime, put back together and that should do the trick.

If you're like me and didn't pay attention when you were taking your mouse apart you can watch this video: https://www.youtube.com/watch?v=hCkDOAxf5MA&t=15m42s

share|improve this answer

Thanks for reminding me about this question by replying to it. It's my fault not to provide the answer, which I indeed found. It was sending the mouse to the vendor where they tested it and confirmed the defect. I was given new mouse replacement which served me well for very long. It began to behave strange again now, after nearly 5 years. The scroll wheel doesn't really scroll sometimes. But I'm still very happy with the overall performance.

Thanks for you help people!

share|improve this answer
    
I'm glad you fixed the issue! You can mark this as the accepted answer if you wish. Click the outlined 'tick' under your vote count :) –  Robotnik Oct 9 at 6:57

Clean it out. Take the three screws out under the stickers on the bottom. Slide the wheel and carrier out and remove all the built up dust and hair. When you remove the wheel you can easily loose the ratcheting lock but I prefer mine removed anyway. It speeds up scrolling.

share|improve this answer

The answer given about the lens & light sensor being dirty solved my wheel issue (it wouldn't let me respond to his comment due to me being a new user).

For me the wheel was very lagged and usually took a full spin just to get a single response or sometimes it wouldn't respond at all.

Open mouse (3 screws under stickers, and after removing top cover the wheel lifts up and out, then be sure the lens and sensor are clean (indicated by red arrows in pic) in my case the sensor on right side was dirty. the wheel now works like new again I actually had to get used to how sensitive it's suppose to be.

sensors: http://i.imgur.com/CkDvN9a.jpg

share|improve this answer

Well I have tried to shake it and some other violent methods but the problem most likely was in a cable or connectors located near the wheel, not in the sensor or wheel itself. It might be that cables are somehow damaged or broken in a way and some strong shaking could have fix it temporarily but what helped me was to generally straighten them up and try to bend them in a way that made my scrolling work again. Might be simple as that.

share|improve this answer
    
Shaking and "other violent methods" are not recommended ways to fix electronics. As such, I have to down vote this as an answer. –  YLearn Jun 18 at 20:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.