Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Ubuntu 10.04 installed on my Mac using Oracle VirtualBox. My machine is connected to Wi-Fi and am able to browse the internet from within Ubuntu as well. However, iwconfig does not give an option for wlan0.

Could someone help me out? What am I doing wrong here?

iwconfig
lo        no wireless extensions.
eth0      no wireless extensions.

The output of lspci is

00:00.0 Host bridge: Intel Corporation 440FX - 82441FX PMC [Natoma] (rev 02)
00:01.0 ISA bridge: Intel Corporation 82371SB PIIX3 ISA [Natoma/Triton II]
00:01.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:02.0 VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter
00:03.0 Ethernet controller: Intel Corporation 82540EM Gigabit Ethernet Controller (rev 
                                                                                       02)
00:04.0 System peripheral: InnoTek Systemberatung GmbH VirtualBox Guest Service
00:05.0 Multimedia audio controller: Intel Corporation 82801AA AC'97 Audio Controller (rev  
                                                                                      01)
00:06.0 USB Controller: Apple Computer Inc. KeyLargo/Intrepid USB
00:07.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 08)
00:0d.0 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI   
                                                                    Controller (rev 02)
share|improve this question

migrated from serverfault.com May 9 '12 at 2:46

This question came from our site for professional system and network administrators.

1 Answer 1

Your virtual guest does not see the wifi interface in your host machine. Instead, it sees a virtual NIC presented by VirtualBox.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.