Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I store my music on a network share and was annoyed that music programs default to using the hidden %userprofile%\Music directory, which is the default location for the magic "My Music" folder.

So I right-clicked on the "My Music" folder, went to the location tab, and changed it from %userprofile%\Music to \\NAS\Music. It appeared to work, and my music player -- which had automatically added the "My Music" folder to its list of directories to watch -- began indexing the music on my NAS share. So far so good.

But now, a few minutes later, I've noticed that the "My Music" folder has disappeared, and the %userprofile%\Music folder (which was previously hidden) is now visible and I am unable to access it. Trying to open the defunct Music folder produces ...Music is not accessible. Access is denied.

I opened the folder properties, and the elevate-privileges "Continue" button takes me to the same place as the Advanced security settings -- a message that I do not have permission to view the object's security properties and suggesting that I try taking ownership. My user and the local Administrators group are the available options, and trying to change the owner to either produces Unable to set new owner on Music. Access is denied.

Opening Windows Explorer as Administrator produces the same result, and trying to cd into the directory or delete it with an elevated command prompt also produces Access is denied.

How do I either:

  • Change the magic "My Music" folder back to a local directory so I can try this again
  • Modify/delete the unusable Music folder
share|improve this question

This worked for me, but I had a somewhat different issue with the music library:

In Safe Mode, disconnect your computer from the network/prevent access to the NAS device, change the "my music" location back to the proper (local) one, and then restore access.

When it can't see the remote folder, it stops returning permissions least, it did for me. Hope it helps!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.