Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

A folder is mounted on a web server (Apache) with NFS but this server can't see the folder. I can see the folder but Apache cannot:

Starting httpd: Warning: DocumentRoot [/mount folder/.../] does not exist
Warning: DocumentRoot [/mount folder/.../] does not exist

NFS config /etc/export

/folder          192.168.x.x(rw,subtree_check,all_squash)

On client /etc/fstab

192.168.x.x:folder/ /folder nfs rw  0   0
share|improve this question

Easier way then taking away SELinux protection is simply to allow use of NFS to it:

setsebool httpd_use_nfs on
share|improve this answer

I found solution !

In the web server, edit /etc/sysconfig/selinux and disable this.

share|improve this answer
That compares closely to 'I have problems with lock, so I removed the lock. Things do now work'. They do, but please realize that you just disabled a security feature that was enabled by default for a reason. – Hennes Sep 10 '13 at 12:25

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.