Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Since I restarted windows to install updates, Postgres stopped starting as a service. I thought it may be a permissions so I gave everyone the ability to to modify the postgres install folder. I then tried to run the database using the start and it works. But when I try and start the service I get the following message: service on local computer started and stopped.

I then tried to re-install Postgres but it got to the end and it was not able to start.

Any help would be great.

share|improve this question
    
What exactly is the error message? –  chmod May 9 '12 at 15:55
    
The postgresql-9.4 - PostgreSQL Server 8.4 service on local computer started and then stopped. Some services stop automatically if they are not in use by other services or programs. –  Steve May 9 '12 at 16:00
    
have you try looking in Services ? type (go to run and type services.msc) loook for postgresql see if the startup type is set to Automatic. –  chmod May 9 '12 at 16:03
    
Yep, it is set as automatic. I tried to start it and it gave me that error. I have restarted the box just incase and it give me the same error –  Steve May 9 '12 at 16:07

1 Answer 1

up vote 1 down vote accepted

The solution to the problem was to completely uninstall Postgres and re-install it. I made sure I deleted all traces of it from the disk before re-installing. That seemed to be the only way to get it working.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.