Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How can I debug an issue with Xubuntu 12.04 (fresh install) which just waits idle after a login for about 30 seconds?

The login screen is delayed correctly. After login, I get my desktop background, but no panels or auto-starting apps.

It doesn't seem to be an authentication/pam issue, because I can login without delay at the console while the graphical session is still stuck. There's no disk or cpu activity and no obvious respawning of any process when I look at htop. There's nothing obviously wrong in .xsession-errors. Most interesting errors:

openConnection: connect: No such file or directory
cannot connect to brltty at :0
WARNING: gnome-keyring:: couldn't connect to: /tmp/keyring-wFn4VR/pkcs11: No such file or directory
...
(polkit-gnome-authentication-agent-1:2131): polkit-gnome-1-WARNING **: Failed to
 register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The nam
e org.gnome.SessionManager was not provided by any .service files
** Message: applet now removed from the notification area
** Message: using fallback from indicator to GtkStatusIcon
...
(xfce4-indicator-plugin:2176): libindicator-WARNING **: IndicatorObject class does not have an accessible description.
...
(xfce4-indicator-plugin:2176): Indicator-Application-WARNING **: Unable to get application list: Operation was cancelled

Bootchart seems to end before I login, so it's not that helpful.

Where else can I look for information?

share|improve this question
    
While I don't know of a fix, I can tell you it's not just you. I have the same issue. –  Sean W. May 9 '12 at 23:01
    
You write "the login screen is not displayed" but yet you are able to log in and at least your session starts to build. So it appears that your login manager at least is working. Does this occur for all users? Even with a new profile? –  Bram May 18 '12 at 16:23
    
@Bram My silly mistake, thanks for spotting it. Corrected to "The login screen is delayed correctly.". It's a completely new system, clean account was affected. –  viraptor May 18 '12 at 21:56
    
Anything in /var/log/Xorg.*.log? Is this a full install or did you manually select packages and are perhaps missing some component? –  Bram May 19 '12 at 12:46
add comment

5 Answers

As long as those slow logins happen with Xubuntu 12.04, 64-bit you can use the following patch as a workaround according to https://bugs.launchpad.net/ubuntu/+source/accountsservice/+bug/996791 (lightdm is patched):

sudo add-apt-repository ppa:andreas-diesner/lightdm-fix-temporary
sudo apt-get update
sudo apt-get upgrade
share|improve this answer
add comment

I finally found a workaround solution here. Ignore posting #15 (seems not to work as I tried). The same author (thanks to Orbital_sFear) has a second solution in #20 which worked for me (and others).

  1. Store the attached tar file: http://ubuntuforums.org/attachment.php?attachmentid=217600&d=1336595748
  2. Extract the tar file to /usr/sbin/ (lightdm-safe and lightdm-restart)
  3. Ensure the permissions on the files are correct.

    cd /usr/sbin
    sudo chown root:root lightdm-safe lightdm-restart
    sudo chmod 755 lightdm-safe lightdm-restart
    
  4. Edit /etc/init/lightdm.conf. Change the line that reads:

    exec lightdm
    

    to read:

    exec lightdm-safe
    

You can have extra arguments after the lightdm-safe script, they get passed through to lightdm. I have --log-file=/var/log/lightdm for arguments on mine.

I'm on a 64bit machine. The 32bit version of Xubuntu 12.04 seems not to have this problem.

share|improve this answer
2  
Welcome to Super User! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Bob Jun 12 '12 at 7:18
add comment

Can you post ~/.xinitrc? In my .xinitrc I have this line exec startkde. Just replace startkde with any windowmanager. But it seems like X-window is broken. I've a similar problem I start my windowmanager but my desktop is all black and don't have a panel or context menu on right click. However I've the x-console and a x-terminal so I can work out the problem.

share|improve this answer
add comment

My simple solution/workaround to this (that works for me) is to install the unity-greeter. After this I don't have the problem anymore.

sudo apt-get install unity-greeter

Then change your lightdm configuration to this:

sudo vim /etc/lightdm/lightdm.conf
# change greeter-session from lightdm-gtk-greeter to unity-greeter

Thats it. If you like, you can then customize the login using the following steps:

xhost +SI:localuser:lightdm
sudo su lightdm -s /bin/bash
dconf-editor

Then go to "com > canonical > unity-greeter" and change as you wish.

share|improve this answer
add comment

I've figured out what causes the problem on my system, and seems to apply to others as well (from other forums as well).

After I ran the first update, my login started slowing down big time. I've dabbled a little bit with the programs in Settings -> Settings Manager -> Session and Startup, and tried closing and opening these programs, and then rebooting.

Anyways, I narrowed it down to a combination of 2 processes, "Network" (the connection manager) and "Xfce Volume Daemon" (could be different on your system, but anyways). The corresponding terminal commands are (as shown in /etc/xdg/autostart):

~$ nm-applet
~$ xfce4-volumed

If I disable them, and then run them in the terminal after login is complete, everything works just fine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.