Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I try to delete a photo or save an edit and it does not work. When I try to save I get a message

Unable to write redeye due to disk error. The disk may be full or read only

When I try to delete nothing happens and the photo is still there. This on a MacBook Pro running OS X Lion with plenty of disk space.

share|improve this question
I am able to view the picture in Finder and can delete it from there. Somehow Picasa cannot delete or write to the disk. – Paul May 10 '12 at 23:10
Have you tried repairing disk permissions? Does it happen to all images? – slhck Jun 21 '12 at 7:48
I didn't mention that I have about 30k pictures in Picasa. I wonder if I am reaching the limit? – Paul Jun 29 '12 at 19:28
up vote 1 down vote accepted

When you do a red-eye (or a retouch) fix, Picasa immediately re-writes the photo (while stashing the original, un-edited version safely in a hidden folder in the same folder as the original photo). The error is saying that when Picasa tries to write to the disk where the photos reside, it is getting an error back from the operating system (or from itself).

The thread Unable to write all files due to a disk error sums up all the known reasons for that error :

  1. The "Export location" (at the top of the Export to Folder window) might be set incorrectly. The solution is to click the Browse button and change it.
  2. The folder you are trying to export to is set to "Read only". Again, try another location or change the permissions on that folder.
  3. Picasa's internal bookkeeping may not have kept up with you (especially likely on a slower computer) and you just need to give it time to catch up.
  4. You might be using a network file system that does not work reliability with Picasa.
  5. A programming bug or some non-optimum code that causes this issue on some computers (but clearly not on most computers, since most people do not have the disk error problem)

To which I add another : Some antivirus or disk-indexing product might be locking the file, so give it time to finish. (If it is Picasa that is locking the file against itself, this will never finish.)

The thread Picasa 3.8 can't edit JPG saved with Gimp 2.7.1 has more to say :

That "Unable to write all files due to a disk error. The disk may be full or readonly" error in Picasa seems to be a real "catch all" error... it is issued when some sort of error happens during an export... it's not at all specific enough to be helpful.

Here's the workaround I'm using: when exporting a .jpg from GIMP (I'm in 2.8, Windows 7) use the "advanced options" and un-check the box "Save XMP Data." The resulting file works ok in Picasa for me.

This seems to say that the error you are seeing may not really be a disk problem, but only a Picasa general catch-all message. If no other solution works for you, try to edit the photos in another way, maybe converting them to another format or stripping out all metadata.

The thread Trying to fix error msg: Unable to write redeye due to a disk error goes further:

I renamed the file to newimage.jpg and everything is good to go. I think picasa is having issues with the format of the extension "jpeg".

From Red Eye error message :

The red eye removal feature only works on photos stored on my Mac or another Mac OS Extended formatted drive; on FAT file system external storage devices (network drives, USB drives), the error message appears.

From I retouch a picture and a window comes up :

I'm not sure how the Red Eye function works but I suspect it uses a lot of scratch disk space. How long has it been since you used Disk Cleanup, defraged, cleared the caches, Recycle Bin, etc.

Try also to update to the latest version of Picasa, as this may simply be some bug that is causing the problem. If all else fails, you could try to contact the developers through the Picasa Forums.

share|improve this answer
I have checked the files and they are not set to read only. – Paul Jun 28 '12 at 3:08
Read-only is only one possibility. There are quite a few others. – harrymc Jun 29 '12 at 7:34
The problem seems to happen when I first open Picasa. If I let it sit for a while I am able to edit/delete pictures. @harrymc suggested: Picasa's internal bookkeeping may not have kept up with you (especially likely on a slower computer) and you just need to give it time to catch up. – Paul Jun 29 '12 at 19:24

I found out through Googling that this problem is due to read only properties of the files. So you have to check that your images are not set to read only. Also it's worth to try uninstalling and re-installing Picasa.

From this source

Where are the photos located when you try to edit them? They can't be edited on DVD, obviously, because they are read-only on DVD and can't be changed in any way. If you have copied them to a folder on the hard drive, check to see if they are still read-only. `

Also form this discussion

Hmmm.... Those two edits (red-eye and retouch) are the only edits that get immediately applied to the JPEG on disk. All other edits are "remembered" and so there's no real work Picasa has to do in those cases.

I suspect you'd also see the same error if you did any edit to one of those photos and tried to save the edit (e.g., a File -> "Save").

I'd guess that maybe the photo you're is marked "read only"? Or, maybe you have a folder called "Originals" in that folder? When Picasa re-writes a photo, it stashes the original photos in a hidden "Originals" folder that it creates in the same folder as your photo. I kind of suspect that if you had a folder with that name in there, that might result in something like what you're seeing...

Try doing a save of a simple edit. Make sure you have to folders of your own called "Originals" See if you can create a folder called "Originals" in the same folder as one of the photos you're trying to save...

From Google product forum

I've been playing with the new built looking for problems. I may have stumbled upon a solution to the disk error problem.

I attempted to Export some files and got "Unable to write all files due to a disk error. This disk may be full or readonly." I have over 120 gigs available and the files are not marked read only.

I noticed on the Export to Folder page the "Location of exported folder" was the address of the memory card used to download the photos. Once changed to another drive, Export worked correctly. It appears the default for the Exported Folder is the last source used. Obviously, attempting to Export back to a memory card that's not plugged in won't work.

share|improve this answer
With a Mac there really isn't a uninstall/reinstall option. – Paul Jun 28 '12 at 3:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .