Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Some keys on the keyboard on my HP Pavilion 2000-428DX press another key at the same time, which renders it unusable.

If I press   I get
----------   -------
ESC or Q     ESC + Q
G or R       G + R
E or F4      E + F4
H or U       H + U
Backspace    Backspace + something else (don't know what, it's not a character)

This happened after installing the spanish MUI language for Windows 7 x64 SP1. I don't know if it has any relation, through.

Anyone knows how can I fix this? I'm unable to send it to service support, since I bought it abroad.

Also, if this is not the right place to ask this question, would you point me to the right place? Thanks!

UPDATE: Just booted the machine with a live Ubuntu cd, and problem still persists, so I can confirm it's a hardware problem.

share|improve this question
    
Have any liquids been spilt into the keyboard? You get this behaviour where multiple circuits are closed due to liquid, so multiple keys fire. Or perhaps some corrosion further in is causing crossover in address lines. –  Paul May 10 '12 at 1:17
    
Hi @Paul. No, no liquid, food or cigarrete smoke was in contact with the laptop. Also, I must mention that I bought it new last week, and the problem started on the third day of use (actually, it has less than 10 hours of use). –  Pablo May 10 '12 at 15:59
    
It is most likely a manufacturing defect, the ribbon cable from the keyboard to the motherboard is kinked or snagged in the case somehow to the point that it is creating a circuit. Perhaps. Perhaps it is broken. To eliminate software as a cause, boot up a linux LiveCD (ubuntu for example) and see if the keys work properly. –  Paul May 10 '12 at 23:18
    
Thanks @Paul. Just tested with a live Ubuntu, and problem persists, so I can confirm is a hardware problem. –  Pablo May 13 '12 at 17:47
add comment

1 Answer 1

Go to control panel > Region and Language > Keyboards and Languages > Change Keyboards and make sure that the setting there match your keyboard.

share|improve this answer
    
I tried that already, but even when changing the language, I still get the extra keys pressed. –  Pablo May 10 '12 at 16:00
    
Have you tried removing the Language pack that you added? If that fixes it then you'd know that is has to be a setting of some sort –  djmadscribbler May 10 '12 at 16:04
    
Well, I haven't. I'll try that out and see if that has any effect. –  Pablo May 10 '12 at 20:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.