Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I built an HTPC so I invested in a Bluetooth keyboard and trackpad as my couch potato remote control.

My dual band router is located in my home theater setup to provide wired access to many all of my theater peripherals (as opposed to using a slower wireless connection).

The trackpad experiences some lagging, but the keyboard is unusable. Letters take anywhere from 1-30 seconds to appear and some buttons are repeated indefinitely as the bluetooth connection is lost.

I'm almost sure that this is a 2.4GHz band interference problem; my question is how to mitigate the interference?

Which is more likely to cause interference that renders my Bluetooth keyboard unusable: the router or a wireless card in the computer?

I've opened up the 5GHz band on my router to serve my laptop, but unfortunately there isn't a way to disable the 2.4GHz band (and my iPhone 4S is relegated to the 2.4GHz band anyways).

Needless to say a wired option for either the keyboard or mouse are out of the question for an HTPC.

Access Point: Time Capsule - 2.4ghz band operating on channel 11, 5.0ghz band enabled (automatic channel)

share|improve this question
    
Can you turn off the wifi router for a minute to confirm? –  Paul May 10 '12 at 1:14
    
Sorry, I forgot to mention -- Router off: keyboard works. –  Roy May 10 '12 at 1:22
    
I think your best option here would be to relocate the AP as far from the bluetooth dongle as possible. This might achieved easier with the BT as a long USB extension would not impact performance. Alternatively, invest in a keyboard/mouse that operates at 27Mhz. –  Paul May 10 '12 at 1:35
    
From a sciency stand-point would it be possible to insulate the signal on one side (the side the AP is located) with some sort of metal, or would the signal be about the same from all sides? –  Roy May 10 '12 at 2:24

3 Answers 3

The long story is here

The summary...

Bluetooth devices operate within the 2.4 GHz band. The difference is that that Bluetooth uses frequency hopping (at 1,600 hops per second) to hop 1mhz at a time over the entire 2.4 GHz band. WiFi (B and G), on the other hand, uses direct sequence and only occupies approximately one third of the 2.4 GHz band. As a result, Bluetooth hops all over WiFi transmissions.

You can try pushing your WiFi channel usage up to 11, but honestly, the nature of the two beasts means there is going to be interference.

Your best bet is most likely going to be to re-position the router somewhere else, or put the computer somewhere else. You could get a simple switch to wire all the devices near the TV to, and cable that to the router after you put it somewhere else. But basically, you will have to reconfigure your setup.

share|improve this answer

Bluetooth devices can employ tricks like Adaptive Frequency Hopping (AFH) to avoid interference from Wi-Fi, but if you're doing 802.11n with wide channels (40MHz wide, instead of the traditional 20MHz channel width), you're not leaving enough free space in the band for Bluetooth. Also, Wi-Fi/Bluetooth combo cards/modules can do other co-existence tricks.

So first, see if you can force your AP to do 20MHz-wide channels only (HT20) on the 2.4GHz radio (if you're using an AirPort Extreme or Time Capsule, don't worry about it -- they already limit themselves to HT20 in 2.4GHz as a "good neighbor" policy). Also, make sure your AP's selected 2.4GHz channel is at one end of the band or the other: channel 1 or 11.

Second, separate your wireless router from your HTPC by at least 2 meters. Try not to keep them in the same media cabinet. But if you absolutely must, at least put them in diagonally opposite corners of the media cabinet. By the way, make sure you've disabled the Wi-Fi on your HTPC.

Third, see if moving 2.4GHz devices away from your Bluetooth keyboard and trackpad helps. For example, if you're sitting on the couch with your HTPC Bluetooth HID devices next to you, but with your laptop on your lap and your iPhone in your pocket and your iPad on the coffee table, try turning off the Wi-Fi and Bluetooth on those other devices and see if it makes a difference.

Fourth, see if you can turn down the power on your AP's 2.4GHz radio.

share|improve this answer
    
I tried moving the AP and HTPC as far away as I could within the media center cabinet without any luck. I might just order some longer Cat5 cables and try it on a nearby shelf. I hadn't considered the other 802.11 devices (in my pocket and on the couch). Apple introduced AFH way back in 2003 as some sort of amazing solution; almost ten years later it still doesn't seem to play nice with that wifi signal. –  Roy May 10 '12 at 11:20
up vote 0 down vote accepted

In fact, it was a bad bluetooth adaptor. Sabrent $10 POS couldn't handle two bluetooth input devices (trackpad and keyboard). I grabbed a Rocketfish MRBTAD on ebay for 6.99 (shipping included) and I'm typing on the keyboard now.

Moved the AP back into the home theater so I have everything wired up again. Thanks for your help anyways guys.

For your reference, don't buy this guy:

http://www.amazon.com/Sabrent-Wireless-Bluetooth-Adapter-BT-USBT/dp/B002SBF108

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.