Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The Visual Studio 11 installed on my system does not apply the color scheme related to XML for the related documents (.config, .xml).

Web.config file in VS2011 IDE

I tried checking the Tools->Options-Fonts and Colors, but that screen is missing all display items related to XML Fonts and Colors missing XML related entries

I have tried the following to troubleshoot this issue and have failed:

  1. Tools -> Import and Export settings... -> Reset all settings

  2. Tools -> Import and Export settings... -> Import (few of my favorites from http://studiostyl.es/)

I have installed further version of VS2011 on virtual machines and they seem to apply the proper color schemes for XML files, and also my VS2010 on the same machine works fine with the XML.

Do let me know of anything that you may think is causing this issue. In the already bleak color scheme of VS2011 working on my instance with XML files are quite unbearable :)

share|improve this question
    
What editor are you opening the XML with? As in right click -> Open With, what's the default? –  ta.speot.is May 10 '12 at 10:23
    
I am not explicitly opening editor (using the default double click). I went ahead and checked the Open with... option, currently Automatic Editor Selector (XML) (Default) was highlighted. –  user53225 May 10 '12 at 10:26

1 Answer 1

up vote 0 down vote accepted

Removing the Beta and upgrading to RC resolved the issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.