Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Is there really a way to use Lync client in a OCS 2007 R2 environment? I've found a registry hack but it does not seem to work.

Key: HKEY_CURRENT_USER\Software\Policies\Microsoft\Communicator
Name:  DisableServerCheck
Value: 1 (00000001)

Is there any other way or any special step to add this hack?

Thanks. Regards.

share|improve this question

Late answer but hopefully it will help someone who finds this from a search. For Lync 2013, I had to use this:

Key: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Office\15.0\Lync
Name:  DisableServerCheck
Value: 1 (00000001)

NOTE: You may need to create some of the keys.

share|improve this answer

What you have done should work, as witnessed by numerous people in the thread :
Using Lync 2010 client in Office Communications Server 2007 R2 environment.

However, there seem to be several possible gotchas, having to do with older installations of OCS on the same computer.

A guy named haytham in the above thread found that :

I solved the problem and it work fine now, what i did is installed the old ocs client, do the registery changes then installed the lync client then it works :)

in the beginning i was uninstalling the old client before install the new and was not working i think it need to not unistall the old ocs 2007 client just upgrade it to new ver.

I suggest to read carefully the thread and all comments to try and see what the problem is.

share|improve this answer
Hi harrymc, Thanks for answering. I've tried all the things mentioned in that website (that was my source by the way) and nothing seems to work. Also I couldn't find any official document on that hack, but I'm starting to believe that there's an option for the server administrator to override that setting. – Matías May 15 '12 at 23:08
Yes, this has worked correctly for too many people, so it must be something that is particular to your setup. – harrymc May 16 '12 at 17:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .