Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever I execute a command in tmux, for example, set status, the status bar turns yellow and echoes back the results of the command. I find this behavior rather obtrusive. Can I turn this behavior off?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

You can set the quiet server option to suppress many of the messages that are displayed in the status line (including the message shown by set-option). This will not suppress messages that come from using the display-message command.

If the quiet option is too broad*, or you want to be able to review the messages with show-messages, then you might try setting the display-time session option to a very small value. This will affect all messages (even those from display-message), so it also may not be appropriate for all situations.

If you are only interested in suppressing the message from that one set status command/binding, and you are comfortable building software from source, then you might want to try out the current SVN trunk. Its set-option command has a -q option that suppresses the normal informational message (i.e. set -q status). This will be included in the next release (i.e. 1.7).

*quiet is is a server option, so it will affect all your sessions.
quiet prevents the message from being entered into the show-message message log. By default, (prefix) ~ is bound to show-messages.
display-time must be from the range 1–750. So zero is not a valid value, but the minimum value (1 millisecond) will probably be too fast to notice in most circumstances (e.g. unless your tmux server is on the other side of a slow link).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.