Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Firewall (kaspersky/avast) blocked messages when I using websocket server (socket.io on node.js), what can i do? (except change default setting in firewall) port 8080 or 8000 thx a lot

share|improve this question

migrated from stackoverflow.com May 11 '12 at 3:49

This question came from our site for professional and enthusiast programmers.

    
Do you mean it is blocking incoming connections to port 8080 and 8000? –  kanaka Mar 14 '11 at 23:17
    
1. with avast don't working websockets and flashsockets protocol, 2 KIS blocking outcoming messages even by AJAX multipart streaming –  Bart Mar 15 '11 at 6:41
    
sorry I didn't understand your comment. Can you clarify your setup? Which system is running the browser, which system is running socket.io/node.js, and where the "firewall" is running? Also, please try temporarily disabling your firewall software (make sure you are behind a router with basic firewalling first) and see if that gets things working. Then post you config and results of that test. –  kanaka Mar 15 '11 at 14:34

4 Answers 4

up vote 3 down vote accepted

I can tell you 100% that Avast for example blocks not only websockets, but from what I see from my Socket.IO app also xhr-polling and other stuff.

This is unacceptable, I've even tested on port 80 and it doesn't work. What an awful piece of software.

Edit: this is a list of blocked ports by antiviruses

share|improve this answer

Many ISP companies block the port 80 to prevent their customers of hosting a web servers on their home computers.

It might beyond your power to unblock the port 80 from your ISP.

Also, as far as I am concerned, Avast is not a firewall.

share|improve this answer

You can try to use port 443 (which is used for https) if it's possible in your case.

share|improve this answer

Node.js has major security flaws, i strongly suggest you move to PHP. unless you don't mind grant ANYONE and EVERYONE with complete authority.

The firewall issue is common, you need to make sure your port is accepted on your network (in this case it probably is since you are getting a network blocked error).

To allow access from the port your have 1 of 2 options, either disable the firewall (not suggested unless its a home based firewall which is a complete joke) or you can allow an exception in your firewall settings.

I suggest you look here: https://www.youtube.com/watch?v=YGpd9lc4CCE http://labs.iqfoundry.com/muir/av.php

There could be several reasons why your firewall is blocking your connection but both of those are primary reasons.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.