Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In XP, if you minimize the current window, it goes to the end of the list for Alt-Tab purposes. In Windows 7, if I minimize a window and then Alt-Tab, I go right back to that window I was trying to get rid of.

Is there a way to make minimize push the window to the end of the list, or some other way to manage the Alt-Tab list order?

Edit: I apologize for saying that this is how Windows 7 behaves. It turns out that Windows 7 sometimes gets into a state where Minimize does not put the window at the bottom of the z-order. I cannot figure out exactly what steps cause Windows 7 to get into this state, but I must do it pretty frequently because this bugs me all the time.

So, when Windows 7 is in this state, here is what happens:

  1. Open multiple windows. I usually have them all maximized.
  2. Press Alt-Tab. Call this window "A".
  3. Press Alt-Tab. Call this window "B".
  4. Minimize window "B". Window "A" is now visible.
  5. Press Alt-Tab.

At this point, I see window "B" again, even though it should have been at the back of the Alt-Tab list (or Z-ordering as it's called).

When Windows 7 behaves this way, I've tried adding the AltTabSettings registry entry. This changes the appearance of the Alt-Tab dialog, but doesn't change the Z-ordering effect of the Minimize button.

When I just now tried to reproduce this, Minimize works properly (pushes window to end of Z-order). I haven't yet been able to pinpoint what changes this behavior.

share|improve this question
    
Status no-repro. –  NGLN Oct 16 '12 at 21:08
    
@NGLN, you're saying that when you minimize a window in Windows 7, it goes to the end of the Alt-Tab list? –  Jeremy Stein Oct 17 '12 at 14:14
    
This drives me mad too! Most of the time minimizing the window puts it at the end of the list, but at some point while I'm using the PC that changes and minimizing it leaves it at the beginning of the list. It's the inconsistency that really annoys me. –  Alan Third Feb 7 at 10:57

5 Answers 5

Instead of minimizing, hit Alt-Esc. This will put the window at the bottom of the Z-order.

share|improve this answer

I don't know if there's a way to change the Z-order of a specific window (other than the method that Jeremy suggested) but you can cycle through the list in reverse order if all you wish to do is Alt+Tab through the rest of the windows:

  1. Minimize the window
  2. Press Alt+Shift+Tab
  3. If you continue to hold down Alt+Shift, you can cycle through the list in reverse order by pressing Tab

If you follow these steps, the window that you just minimized should appear last in the Alt+Tab list order.

share|improve this answer

From a similar question Getting back the old alt-tab windows switching behavior in Windows 7?:

To restore the XP Alt-Tab functionality simply, lauch regedit, add a DWORD named AltTabSettings to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer and set its value to 1.

You need to restart Explorer for changes to take effect (restarting your computer is an easy way to do this)

Personally I prefer the 3D Aero flip (Windows Key + Tab) which (on my system at least) pushes minimised apps to the back of the stack

share|improve this answer
1  
? The WindowsKey+Tab doesn't push minimized apps to the back of the stack for me. It behaves in the exact same way as when I press Alt+Tab (with the only exception that it select the currently focused window first) –  p_strand Oct 17 '12 at 14:31
    
Are you using Windows 7? As far as I know I have no add-ons or tweaks that would change this behaviour. –  James Oct 17 '12 at 14:32
    
Yes. Windows 7 Professional 32-bit. I don't have any add-ons or tweaks either AFAIK... –  p_strand Oct 17 '12 at 14:33
    
Strange - I would be interested to know what other peoples' experiences are. As far as I can tell, the registry tweak I posted should work though. –  James Oct 17 '12 at 14:37
    
This changes the Alt-Tab dialog. It does not change the Minimize behavior. Someone else posted the same thing and then deleted it when they realized it was wrong. Please leave up this answer for others to see, since it's pretty common advice on the web, but unhelpful in this question. –  Jeremy Stein Oct 17 '12 at 14:55

It would surprise me a lot if there was a way to force Windows to change the way it does alt-tab. The only tweaks I know of have to do with the look of the alt-tab window, rather than with its algorithms.

You might instead be interested in one of the following two alt-tab replacements, which might better suite your working habits :

VistaSwitcher

image1

Switcher

image2

share|improve this answer

I think this article explains what's going on and why sometimes a minimised goes to the back, and sometimes not.

share|improve this answer
1  
While the link might provide an answer it can quickly become outdated. Please include the main points from the link in your answer. Thanks. –  Matthew Williams Jun 9 at 11:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.