Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

It doesn't matter what I do, create new SSH keys, add them manually to Heroku, delete all keys from Heroku and add a new one, force delete the entire ~/.ssh folder, overwrite id_rsa keys, create ~/.ssh/config file, create a keygen with -C flag, create a dsa key pair instead of rsa, deleting the keychains from the Keychain Access utility in Mac OS X, and I've just about every SU question on this.

But I keep always getting the same error message, with the same fingerprint when I run

$ git clone -o heroku

Warning: Permanently added the RSA host key for IP address 'x.x.x.x' to the list of known hosts.

 !  Your key with fingerprint 48:dd:XX...XX is not authorized to access app-name-0000.

fatal: The remote end hung up unexpectedly

I remember having this problem some time ago with Github and gave up. I really stumped as to what to do. (Reinstall Mac OS X?)

share|improve this question
ssh-agent -D perhaps? – grawity May 11 '12 at 16:20
up vote 1 down vote accepted

OS X has an SSH agent running in user sessions; use ssh-add to manage keys.

(I hope you are not serious about removing keychains in Keychain Access; removing the wrong one will lock you out of your account, and you may not be able to recover easily.)

share|improve this answer
It works :) Cannot believe how ridiculously simple that solution was. I can now clone and push to origin master with git. And don't worry, I deleted only what one user instructed, I didn't touch anything else. Thanks – Adam-E May 11 '12 at 18:31

Take a look at this heroku help file. You have to manually match the provided SSH key to this fingerprint: 8b:48:5e:67:0e:c9:16:47:32:f2:87:0c:1f:c8:60:ad

Try removing the entry from ~/.ssh/known_hosts then adding this to ~/.ssh/config:

Host VerifyHostKeyDNS yes

Then accept the warning when you try cloning again.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .