Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

There are some websites (for example ynet.co.il - Hebrew), that keep refreshing themselves every X minutes.

Is there a way to block them from doing so ?

(I use win XP with google chrome)

share|improve this question

migrated from webapps.stackexchange.com May 11 '12 at 18:40

This question came from our site for power users of web applications.

    
May I ask, why you want to do this? Perhaps there is another way to help you with this. –  Michael K Sep 2 '10 at 11:09
    
To stop spam websites giving me adds. –  Tal Galili Sep 4 '10 at 6:14

3 Answers 3

Sites may also implement auto-refresh through plain HTML using the META tag. Almost all the popular browsers have some way of detecting META refreshes.

In Internet Explorer 8: go to Tools > Internet options > Security tab > Custom Level button > Miscellaneous category > check the Disable radio button for the "Allow META REFRESH" option.

In Firefox (I tested in ver 3.6): go to Tools > Options.. and in the Advanced section's General tab, check the "Warn me when web sites try to redirect or reload the page" checkbox in the Accessibility panel.

In Opera, you can go to Preferences > Advanced > Network and uncheck "Enable automatic redirection" checkbox

share|improve this answer
    
Thank you Mvark - what do I do with chorme ? :) –  Tal Galili Sep 2 '10 at 8:18
    
@Tal - it doesn't look like there's an option in Chrome 5. –  ChrisF Sep 2 '10 at 11:13
    
AFAIK, Chrome does not natively support any settings to block META refreshes nor are there any related Extensions currently. I also tried (jaxov.com/2009/11/…) a few Greasemonkey scripts (userscripts.org/tags/metarefresh) but they did not work for me. –  mvark Sep 2 '10 at 12:04

Turning off javascript should work.

A bit of an extreme/crude method, but should be effective.

share|improve this answer
3  
There is no NoScript extension for Chrome, but you can selectively block JS using Chrome's built-in function a.imageshack.us/img820/5060/pic20100902081042.png. –  Marek Grzenkowicz Sep 2 '10 at 6:06
    
Thanks MGOwen and Marek Grzenkowicz. That did the job. Thanks, German –  German Feb 20 '12 at 5:02

Others have had this issue with Chrome. It does not appear possible to disable meta refreshes in Chrome. I couldn't find a bug report for Chrome that directly mentions this, but this one appears related. You might try filing a new bug report.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.