Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Ok this is a sort of solved problem, however i am still interested in what was behind it..

I have been building chromium from source for a while now, and decided to get rid of the src directroy and all of my current builds and start from scratch (change of build config). So i wanted to use rm -rf to delete the ./src/ dir. the ./src/out/Debug/ dir was symlinked to /opt/chrome and the binary was linked on my gnome-Do docky bar.

When trying to rm -rf the src directory, after a second or so i got a total lockup of my gui, nothing responded including attempts to change runlevels. The box still responded to a ping although not having openssh-server installed didn't allow me to try anything else, so i hard rebooted. This happened twice. The third time i removed both the symlink dir and the gnome-Do icon and the delete worked... Does anybody have any clue what happened here and what may have caused it?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

I'd second EmmEff's suggestion. It is fairly common for the system to freeze when some command blocks on I/O operations. This could be due to bad sectors on the disk - check using the fsck or badblocks commands, but make sure you pass in the options to do a non-destructive test. The other, more common, problem is that you're on a network filesystem and experiencing latency in I/O operations.

share|improve this answer
    
use smartctl to get the disk to do self-tests on itself. If it's going bad, buy a new one and copy. Minimize the amount of writes; def. don't use fsck to repair in place on a failing disk! –  Peter Cordes Dec 10 '09 at 20:02

Have you run fsck on this filesystem? There could be filesystem corruption or the disk is going bad in the sectors where these files are/were stored.

I was going to suggest a recursive symlink, but my brief experimentation couldn't trigger the behaviour you described.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.