Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a USB memory stick (Mediastar 4GB) that has decided not to work. I have tried it in Macs and Windows, to no avail.

The symptoms in Windows are that the icon appears in My Computer but cannot be access. The properties show that there are zero free and used capacity. The drive cannot be seen using Disk Management utility.

The symptoms in Mac are that the drive isn't mounted. However, when I plug it in, the system log displays the following:

macintosh-4:dev Mark$ sudo dmesg | tail
... content elided
USBMSC Identifier (non-unique): 0x1307 0x163 0x100

Furthermore, in USB Profiler I can see an entry appear when the device is inserted. I know it is not a power problem because of the information I see in System Profiler.

I don't care about making the key work again, but I would like to retrieve the documents stored within it. Can anyone help? I've tried countless software thus far but they all suffer the same issue: the drive doesn't not appear on their "select drive to scan" screen.

I believe the problem first surfaced when the owner put a Mac to sleep and then awoke it with the USB key still inserted the whole time. I do know that this wasn't the first time they had done that activity, so I don't know if that really was the trigger to the problem.

Any suggestions to help me recover files are very welcome.

share|improve this question
    
Try it on a Linux system and see what happens (anything in dmesg? error messages?). It looks like a filesystem problem. –  Renan May 12 '12 at 17:38

1 Answer 1

It's most probably corrupted. You could try formatting it but that means that you'll lose the contents of the USB :/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.