Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an MSP (Microsoft Patch) file, which installs some updates. But when I run it, it shows an error message, which says, that it cant read the file from C:\Windows\Installer\SomeFileName.msi But this file is there, I checked that out. I tried to run it with Admin rights, from powered cmd, from PowerShell, no luck. How I can fix that situation? Help please.

share|improve this question
    
Try downloading the msp from its source again. It might have been corrupted during download or copying. –  Robert Kerr May 13 '12 at 2:28
    
That doesn't help. Sorry. I downloaded it several times, from several sources. Even its previous patch also in MSP format had the same error message. –  Matubo May 13 '12 at 3:36
    
See if this Microsoft Fixit can help..support.microsoft.com/mats/Program_Install_and_Uninstall –  Moab May 13 '12 at 13:06
    
I tried it, it didnt help. –  Matubo May 14 '12 at 3:03
add comment

1 Answer

up vote 1 down vote accepted

I've found the cause of my problem. As it seems, these programs, which use MSPs should be installed in their default folder, such as "C:\Program Files...". Then these MSP patches work fine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.