Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Acer TravelMate 4740 series laptop.

Brightness control keys (Fn+Right/Left) work on Windows 7, but not on Linux(tried both Ubuntu and Kubuntu).

Linux shows the brightness bar(bulb) when the keys are pressed, it even increases and decreases, but the brightness does not change.

Volume keys (Fn+Up/Down arrow) work perfectly in all OSs.

Any solution? I guess this is a hardware problem with Acer.

share|improve this question
    
I'm on a Acer 5745G and the brightness control has always worked, through several revisions of Ubuntu, so I can exclude that it is a general Acer/Linux problem. –  Daniel Andersson May 13 '12 at 10:32
    
OK. Any scope for a solution? –  Max May 13 '12 at 10:36
    
I had the same problem once and I fixed it as I've explained at joseblog.netau.net/tips-and-tricks/… –  Joseph Aug 11 '12 at 20:10

2 Answers 2

Try adding:

Option “RegistryDwords” “EnableBrightnessControl=1″

To the "Device" section in your xorg.conf.

I had a very similar problem on my Lenovo W510 with Ubuntu lucid and it was solved after setting this and logging out and in again.

Edit:
My laptop is not near me, but searching for a sample xorg.conf on the net I found many "almost duplicate" posts. Here is a sample on a one of them at askubuntu.com http://askubuntu.com/questions/83965/ubuntu-10-04-cant-adjust-brightness-on-my-lenovo-thinkpad

share|improve this answer
    
Here its /etc/X11/xorg.conf.failsafe. Why is this? Please give an example of the contents of that file after adding this entry. –  Max May 13 '12 at 12:59
    
@max I've edited the post and added a link. AFAIK xorg.conf is not a must on Ubuntu any more. Although it was there on my laptop. –  amotzg May 13 '12 at 13:15
    
@max Also, if this solution do solve your problem, to my opinion, the question should be marked a duplicate. –  amotzg May 13 '12 at 13:17
    
I did that and its causing extreme flickering of the screen! And when I press the brightness keys, flickers even more with black bars. –  Max May 13 '12 at 13:43
    
Seems that this is not the solution for you, I guess our problems are different. How did you create the xorg.conf to add the option to? Did you copy from your xorg.conf.failsafe? The other options in the sample may not fit your configuration. –  amotzg May 13 '12 at 14:45

Just add

acpi_backlight=vendor

to your kernel parameters in the grub2.cfg file.

share|improve this answer
    
It helps me with Ubuntu 12.04 on Acer Aspire One D270. –  Lukasz Stelmach Sep 1 '12 at 19:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.