Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have set up a Windows7 VM on Virtual Box. Host OS is Ubuntu Oneiric. I am connected to internet on host OS using mobile connection. I want to use this connection on my VM as well. But I am unable to set up network on Virtual Box.

I googled for the solution. But most of them were either for Wireless or for wired connection. I tried few of them but in vain.

I am a newbie and don't have much idea how to do this. Please help me so that I can connect my VM to the host OS network.

My current network settings are as follows.

$ ifconfig
eth0  Link encap:Ethernet  HWaddr 18:03:73:6c:45:17  
      UP BROADCAST MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
      Interrupt:46 Base address:0x2000 

lo    Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:16436  Metric:1
      RX packets:322 errors:0 dropped:0 overruns:0 frame:0
      TX packets:322 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:35653 (35.6 KB)  TX bytes:35653 (35.6 KB)

ppp0  Link encap:Point-to-Point Protocol  
      inet addr:10.134.80.235  P-t-P:10.6.6.6  Mask:255.255.255.255
      UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
      RX packets:15072 errors:0 dropped:0 overruns:0 frame:0
      TX packets:14818 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:3 
      RX bytes:14028308 (14.0 MB)  TX bytes:1659735 (1.6 MB)
share|improve this question

migrated from stackoverflow.com May 13 '12 at 11:24

This question came from our site for professional and enthusiast programmers.

add comment

2 Answers

up vote 1 down vote accepted

The problem is solved. I changed the network configuration on Virtual Box.

The configuration which enabled networking on guest OS is below.

Attached to:     NAT
Adapter Type:    Intel PRO/1000 MT Desktop (82540EM)
Promiscous Mode: Allow VMs
Cable Connected: Yes

The solution which Parth gave was correct. Its just that Cable Connected was disabled in the configuration.

share|improve this answer
add comment

well, does your host os internet connection is working ? if it is working well then you dont need to establish special configuration. Just enable NAT !

As you have mentioned you are using virtual box, then in virtual box window -> select the guest os -> settings -> Network -> Attached to NAT !

share|improve this answer
    
Yes... my host os connection is working fine. NAT is also enabled. But still VM is not connected to network! –  Mahendra Kariya May 12 '12 at 18:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.