Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is odd, to say the least. I've been quarrelling with my ISP over the past few days, claiming that my router stops transmitting data if I make intense use of the connection, like downloading a large file. I've been using this as a test file, which is a 10G sparse file. After about 4 minutes, the transfer stops, and all other connections on the network are killed, including those on other computers. The cable signal on the router doesn't go away (ie, cable lights on the modem), but there is no network activity, and after 10-15 seconds, things go back to normal. Basically, it's as if I unplugged the modem... without the unplugging part.

This issue isn't new. In fact, it's about 2 years old. There are rumours about my ISP doing this kind of thing on purpose to screw with p2p usage, but I never really believed this. The same thing happened with my previous computer, my wife's laptop, and this new computer, which is 4 months old now. All computers use Arch linux, but are otherwise completely different. Either way, two days ago I decided that I'm not happy about this, and called them.

Why do I blame Linux? Well... I installed windows xp on this computer, and tried downloading the same file. It did download just fine, and the connection never went away. Then I tried downloading the same file on my Android phone, and it went fine.

I'm at a loss as to what might be at fault. There have been a bunch of kernel versions and network drivers involved, always with the same outcome. I've tried curl instead of wget, and also the firefox download manager. The same happens while streaming video with mplayer. I've had the router changed, new network cables installed, I've tried taking out any other network hardware in the middle, such as switches.

I wonder if anyone has faced a similar situation in the past, or might have a clue as to what I should be looking at to pinpoint the issue.

share|improve this question
    
I've had a similar problem in the past (but it was the router which was running Linux) with a particular NIC. Putting a switch between the router and the computer solved the problem for you, but I see that you have already tried that. –  paradroid May 13 '12 at 15:08
    
I've been playing with the tcp stack settings of the kernel, and changing the MTU. Lowering the MTU makes the connection drop quicker, if that's a hint to anyone. Changing things in the tcp stack configuration didn't seem to change anything. –  mkaito May 13 '12 at 16:10
    
Does the router still respond to pings when this happens? If you can access the router, does it have the capabilty to do diagnostic pings? If so, what happens when you ping 8.8.8.8? –  Paul May 14 '12 at 0:42
    
It does not respond to ping during the short void time. –  mkaito May 14 '12 at 3:27
    
After a lot of research, the only thing I can conclude is that I can not solve this issue. –  mkaito Jun 3 '12 at 22:07

1 Answer 1

I know this doesn't look like a lot of fun, but why not doing some Wireshark?

Especially looking at what's going on on the network just before the router starts being unresponsive.

I may be completely wrong but, you should take a look at the ARP tables before/after the "void". For me ARP could be involved since you also get other assets down.

Other than that, it could also be a malformed IP packet or something? In that case sniffing the network would also be interesting.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.