Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a macbook running OS X 10.7.2. I run windows xp as virtual machine using vmware fusion 4.0.2. Recently I updated OS X to 10.7.3 and network does not work anymore on the windows xp virtual machine, any ideas?

share|improve this question
    
What do you mean by not working? Is the network adapter missing in the VM? Does it have an IP? What are your network settings in Fusion? –  evan.bovie May 19 '12 at 5:39
    
This seems to be a widespread issue. –  evan.bovie May 19 '12 at 5:44
    
@flow Can you post your vmnet adapter settings — from OS X terminal, type 'ifconfig' and post the vmnet entries. –  emgee May 22 '12 at 0:08

1 Answer 1

up vote 2 down vote accepted
+50

Try modifying your VM's .vmx config:

How-to from here:

  1. Ensure the virtual machine is shut down (not suspended).
  2. In Fusion, from the Apple menu bar, go to Window > Virtual Machine Library.
  3. Hold the Option (Alt) key and right-click the virtual machine. Select Open Config File in Editor.
  4. If the these lines are missing, add them:

    ethernet0.present = "TRUE"
    ethernet0.connectionType = "bridged"
    ethernet0.virtualDev = "vmxnet3"
    ethernet0.wakeOnPcktRcv = "FALSE"
    ethernet0.addressType = "generated"
    ethernet0.linkStatePropagation.enable = "TRUE"
    
  5. When finished, click Save a version (Lion) or Save (not Save As) (Snow Leopard and earlier), and exit.

The changes made to the .vmx do not take effect until the next time Fusion is opened (quit it first, if it is currently open). Alternatively, double-click the .vmx file to apply the changes and open the virtual machine immediately.

share|improve this answer
    
thanks a lot. I did it but the problem now is that the ethernet card is not recognized after reboot, windows says it needs to install drivers but can not find them, any hints? –  flow May 20 '12 at 13:45
    
Try replacing e1000 with vmxnet3. Make sure you have vmware tools installed. –  evan.bovie May 20 '12 at 19:43
    
Also, specifically, what version of XP are you running? Professional or Home? 32-bit or 64-bit? –  evan.bovie May 20 '12 at 19:45
    
changing to vmxnet3 and now it works, thanks a lot !!! –  flow May 22 '12 at 5:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.