Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On my 21.5" iMac, the volume indicator doesn't work properly.

It started after I installed Sparrow about several days ago. It often disables itself for no reason at all. I've now uninstalled Sparrow and it's still doing the same thing.

Sometimes it disable itself for a few minutes and then enables itself again, sometimes it could be hours before it's enabled again. Sometimes I have to restart the computer a few times to get it to enable again.

I don't know what's the problem is here. I don't know why it does that.

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

This only happens when your primary audio output device is not headphones or the built-in speakers of your Mac. For example, when you connect an external USB or Firewire sound card, or another virtual sound driver such as those from Adobe utilities (Premiere Pro, Media Encoder, …).

I don't think this is related to Sparrow in any way.

When it happens, hold and click your volume icon in the menu bar. If something other than "Internal speakers" is selected, then your audio controls won't work.

So, check what is listed in your case and remove the offending device/program.


If it's actually showing "Digital out", then that means your optical output is stuck. Your Mac thinks an optical cable is connected, when in fact it is not. This could be a hardware or software issue.

You can try the following software fix:

  • Play some music
  • Connect a pair of headphones
  • Open System Preferences » Sound
  • Disconnect the headphones

You could also perform an SMC reset as suggested here – possibly with speakers or headphones plugged in.

Some others suggest this is a hardware problem. With a toothpick, try fiddling around in the headphone port, so that the latch releases again.

share|improve this answer
    
Yes it happened just now and on and off so many times, so freakin annoying. Here i took a screenshot ![screenshot][1] [1]: i.stack.imgur.com/EaoeW.png How do stop it from being disable and enable for 100s of times everytime i use it? It's so annoying when i talk on skype and then its suddenly disable itself for 5mins or something then enable for 1 minute then disable again. –  James1 May 13 '12 at 21:58
    
Have you connected any peripherals to your Mac? Any audio devices? Is the audio out port glowing red? If you haven't connected anything, try playing some music, then connect a pair of headphones. Open up "Sound" in System Preferences and pull out the headphones' cable again. –  slhck May 13 '12 at 22:00
    
No there's no any sound devices connected to it. Here are the screenshots when i don't have any audio device connected and when i plug a pair of earphone in.picasaweb.google.com/104666350471310814512/… –  James1 May 13 '12 at 22:11
    
    
Okay, it seems that there's a hardware issue with that. If you search for "Mac stuck on Digital Out" you'll find lots of people with the same issue. Sometimes, the toothpick method (see my answer) works, sometimes the only solution is having the logic board replaced. –  slhck May 13 '12 at 22:14
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.