Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Kodak ESP C310 printer that I just purchased. I have tried to use the CD, I have used the Kodak and I have tried to use a independent web site for loading my print driver but is fails.

It will load all the way to the very end, but when it gets to the point of installing the driver. It freezes up and it will tell me it loaded, but the drivers were not installed.

I have tried this many times. I know the printer works, because I have loaded it on another computer. I have Vista operating system. I think it is something with the computer.

share|improve this question
Did you try this driver? Did you follow the install instructions on this page?… –  Moab May 14 '12 at 14:48
Do you have a Vista-32-bit driver, a Vista-64-bit driver or some other driver? Is your Vista 32-bit or 64-bit? –  RedGrittyBrick May 14 '12 at 14:48

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.