Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Lenovo W520 with a 1x1 11b/g/n Wireless LAN PCI Express Half Mini Card Adapter and a D-Link DIR-825 using DD-WRT (build 18777). I understand that my adapter doesn't work on the 5GHz frequency band so it can't see the SSID that utilizes it. I am able to connect to the 2.4GHz Wi-Fi network, but I am only connecting at a rate of 54mbps, even when the signal strength is over 80% (according to DD-WRT). It is my understanding that with N and 2.4GHz I could get a hypothetical Tx rate of ~120mbps, so why am I only getting 54? What can I do to increase that rate? I am using Windows 7 Ultimate plugged in with maximum performance.

enter image description here enter image description here

share|improve this question

5 Answers 5

I followed the tips in this article and ended up setting the 2.4GHz Wi-Fi with the following settings:

  • Wireless Network Mode: N-Only. I don't have non-802.11n adapters.
  • Channel Width: Turbo (40MHz)
  • Wireless Channel: Auto
  • Extension Channel: Auto
  • Also set the Security Mode to WPA2 Personal and AES.

That gave me a link speed of 150 Mbps.

share|improve this answer
    
You probably don't want to force N-Only mode, because depending on the AP's implementation, it may keep your N devices from being able to use G and B rates, even when those rates would be better suited than any N rate (such as at the edge of range). –  Spiff May 16 '12 at 2:25
    
@Spiff if I change to Mixed mode I can't use the 40MHz channel width. Changing it to use N/G allows me to choose the 40MHz channel width. –  Jonas Stawski May 17 '12 at 2:04

When using 2.4GHz you have to pay attention to the bandwidth per channel too—to really get high speeds, you need to be able to implement the 40MHz per channel option, and with the 2.4GHz band you are going to need to be able to utilise about 82% of the whole band to achieve that.

Given how noisy 2.4GHz is in most places, that is not going to be feasible in most places, and if you set the bandwidth channel to be "auto" my guess is that it will end up at 20MHz instead.

I have gotten the best results using a dual-radio access point and dedicating the 5GHz radio to 802.11n, leaving the mixed mode or 802.11g only to the 2.4GHz radio for compatibility.

share|improve this answer
1  
In most cases it's best to leave 802.11a rates enabled in 5GHz (so your N clients can fall back to those rates when appropriate, like at the edge of range). Also, there's no advantage to disabling N on the 2.4GHz radio. May as well leave it enabled so 2.4GHz-capable N devices can use it when they want. –  Spiff May 16 '12 at 2:28
    
Actually, that's a good point about not disabling N on the 2.4Ghz band, but it made things easier for me from a usage perspective - I labeled on SSID-n and the other SSID-g - so it was more of a logical division than anything else. –  Adam C May 16 '12 at 8:14

A 1x1 802.11n card (non-MIMO, thus sorta "N in name only" since MIMO was kind of the raison d'être on 802.11n) can only do 72.2 mbps signaling on a 20MHz channel, or 150 mbps signaling on a 40MHz channel. On 1x1 cards that can't do short guard intervals (short GI), those numbers drop to 65 and 135mbps, respectively.

The fact that you have strong signal but not at least the 65mbps data rate suggests that your client is limiting itself to G mode operation for some reason. The most common reasons are:

  1. The AP is not set to do N on its 2.4GHz radio.
  2. Your AP or your client is configured to use WEP or TKIP (WPA1) encryption, not AES-CCMP (WPA2). WEP and TKIP, as implemented by most Wi-Fi gear, is not fast enough to keep up with N rates, so the 802.11n spec disallows using those modes with 802.11n connections. To get N rates, you have to use AES-CCMP or no encryption.
  3. Your AP (or I suppose your client) does not have QoS (802.11e, WMM) enabled. The 802.11n spec requires QoS.

Then, if you really want to give your client a chance at max performance, you could enable 40MHz-wide channel mode on the 2.4GHz radio of your AP. It uses the lion's share of the 2.4GHz band and thus is quite likely to interfere with other things (and be interfered with by other things), but if you want a chance to get 150mbps instead of just 72.2mbps, you'll need to enable 40MHz channel mode. Try to at least lock your AP to one end of the band though, by picking either channel 1 or channel 13 (11 in North America).

By the way, signal strength of "80%" is meaningless, because there's no standard for what that's 80% of, and so those percentages vary from vendor to vendor, product to product, release to release. See a Received Signal Strength Indication (RSSI) listed in negative dBm (deciBels referenced to 1 milliWatt) is a much more useful things, because that's pretty standard (although calibration differences make even make RSSI dBm's a bit variable). But for the sake of this Answer I've chosen to believe that that "80%" actually means you should be getting your top data rates.

share|improve this answer

In DD-WRT set: Afterburner - Disable.

share|improve this answer

It's probably because wifi only connects as fast as your slowest client. If you have another 802.11b/g device connected to the network then you can only connect at 54Mb/s.

If you don't have any other b/g device on the network, try logging into the router via SSH and doing a channel scan (not sure if it's avaialbe from the web interface as I use openWRT) and find a channel that's clear.

share|improve this answer
    
At the moment of this writing there was only one client connected which was 802.11n. –  Jonas Stawski May 14 '12 at 14:31
1  
Are you telling me that the router lowers it transmission rate to all clients because one of the clients has a lower transmission rate? That wouldn't very smart. Plus, all the Wireless clients are using 802.11n adapters. –  Jonas Stawski May 14 '12 at 14:32
2  
@jstawski - That is exactly what edude05 is saying and he is 100% correct. –  Ramhound May 14 '12 at 15:55
    
Actually, the 802.11n spec removes the lowest common denominator issue and allows for multiple speeds - the limitation you are talking about does not apply, assuming of course that the spec is implemented correctly –  Adam C May 14 '12 at 18:08
    
@Ramhound That is a huge myth and it is absolutely not true. Each client communicates with the AP at whatever rate that particular "(client,AP)" pair is capable of, regardless of whether other clients on the same AP have to use slower rates. So in a mixed B/G/N network, the N clients use N rates when its their turn, the G clients use G rates, and the B clients use B rates. Even when they're all connected at the same time. –  Spiff May 16 '12 at 1:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.